Aide Excel fonction Si

Discussion dans 'Windows' créé par Ghost-alone, 23 Janvier 2015.

  1. Offline
    Ghost-alone Elite
    Je viens vous voir avant de ne plus avoir de cheveux !

    Fonction SI pour 2 tarifs , pour 0 à 10personne c'est 250€ , pour les joueurs supplémentaire c'est 20€ par personne. ex: 9=250 et 11=270

    Je dois pas être loin mais je tiens a mes dernier cheveux en vie :p

    =SI(G4>10:beuh:250+((G4-10)*20));0)

    J'arrive pas a lui faire faire que si ya rien dans la colonne ou 0 et bien ça fait zéro , stupide machine !! ok je m emporte :D
    Ghost-alone, 23 Janvier 2015
    #1
  2. Offline
    gregsting Elite
    Si je comprends bien ce que tu veux faire, Ta fonction ne marcheras pas dans tous les cas avec juste un si, tu as 3 cas:
    0 ->0
    0-10->250
    10+x -> 250+20x

    Par contre je ne vois pas immédiatemment comment faire
    gregsting, 23 Janvier 2015
    #2
  3. Offline
    MacEugene POUICbuster
    Code:
    Si G4 = 0
      -> 0
      Si G4 < 10
          -> 250
          -> 250+((G4-10)*20)
    Edit: fait chier il prend pas les espaces
    MacEugene, 23 Janvier 2015
    #3
  4. Offline
    Ghost-alone Elite
    c ça et comment tu l écris dans la cellule ?
    Ghost-alone, 23 Janvier 2015
    #4
  5. Offline
    gregsting Elite
    =SI(A1=0;0;SI(A1<10;250;250+20*(A1-10)))

    Testé dans openoffice
    gregsting, 23 Janvier 2015
    #5
    eGm_ aime ça.
  6. Offline
    Azinou Ancienne LV
    Normalement, avec un seul si ça peut marcher. En effet, si tu prend la condition supérieur à 10, si cela respecte, t'as bien ton 250E+ (nombre de participant-10)*20, et dans le cas faux, t'as donc de 0 à 10joueurs = 250E

    Cela donnerait : =SI( A1>10;250+(A1-10)*20;250 )
    Azinou, 23 Janvier 2015
    #6
  7. Offline
    gregsting Elite
    Ouais sauf qu'il s'est mal exprimé je pense, ce qu'il veut c'est pas 250 pour 0 à 10 mais 250 pour 1 à 10
    gregsting, 23 Janvier 2015
    #7
  8. Offline
    Azinou Ancienne LV
    Effectivement :cool: Je trouvais bizarre que, si y a personne, cela couterait quand même 250E, car faut quand même au moins une personne sinon y a pas de commande/réservation x)
    Azinou, 23 Janvier 2015
    #8
  9. Offline
    BenLG Yeah
    Salut

    Je suis pas expert Excel mais bon je tente :)

    =SI(G4=0;"0";SI(G4<=10;"250";SI(G4>10;250+((G4-10)*20))))
    BenLG, 23 Janvier 2015
    #9
  10. Offline
    Skarbone I would rather be snowboarding
    voila

    =SI(A1<1;0;SI(A1<10;250; (A1-10)*20+250))

    (y'a pas d'espace après "250;" mais le forum en fait un smiley sinon)
    Skarbone, 23 Janvier 2015
    #10
  11. Offline
    Azinou Ancienne LV
    Vous avez tous oublié le :
    =Si(esterreur(formule complète);0; (formule complète) ) pour éviter d'avoir des N/A ou autre qui pourraient casser la somme si, par exemple, la colonne du nbre de participant est remplie avec le nom au lieu d'un chiffre.
    Azinou, 23 Janvier 2015
    #11
  12. Offline
    Skarbone I would rather be snowboarding
    suffit de pas confier la feuille a une clinche :D
    Skarbone, 23 Janvier 2015
    #12
  13. Offline
    Ghost-alone Elite
    Parfait ça marche , un tout grand merci les gars :cool:
    Ghost-alone, 23 Janvier 2015
    #13
  14. Offline
    Azinou Ancienne LV
    Ou mieux, faire une validation de données et imposer une données numérique dans la colonne :p Comme ça, même une clinche pourrait l'utiliser x)
    Azinou, 23 Janvier 2015
    #14
  15. Offline
    Ghost-alone Elite
    chaïze !!!
    maintenant ça coince, je voudrai rajouter
    =SOMME(D2*35;E2*45;F2*65;G2*20) avec =SI(G2<1;0;SI(G2<10;250; (G2-10)*20+250))
    Ghost-alone, 23 Janvier 2015
    #15
  16. Offline
    Azinou Ancienne LV
    Explique plus précisément ce que tu veux faire ?

    De ce que je comprend, tu veux inclure une somme de produit au total initial ? Genre, pour inclure le nombre de nuit d'hôtel, de repas, etc etc ? Et là, tout est compté par personne (ce nombre pouvant être différent du total de personne si tout le monde ne veut pas tout prendre) ?
    Azinou, 23 Janvier 2015
    #16
  17. Offline
    Skarbone I would rather be snowboarding
    Oui explique ce que tu veux parce que la... ;)
    Skarbone, 23 Janvier 2015
    #17
  18. Offline
    Ghost-alone Elite
    Un pti dessin vaux mieux qu'un grand discours... :D
    Feuille dactivité de mon paintball :p Différente formule, recharge , boisson,ect...
    Et le seul soucis c la formule kids pour les 7-12ans , c pas un prix fix :-(

    Fichiers attachés:

    • Sans titre.png
    Ghost-alone, 23 Janvier 2015
    #18
  19. Offline
    Azinou Ancienne LV
    Pour ce que tu veux, c'est pas plus simple de simplement coller ta somme de produit à la formule de base ?

    Genre =SI(G2<1;0;SI(G2<10;250; (G2-10)*20+250))+D2*35+E2*45+F2*65+G2*20 ???

    Car, de ce que je comprend, l'occupation de la salle/terrain est le seul coût avec un minimum (250E), tout le reste étant directement lié au nombre de personne ?
    Azinou, 23 Janvier 2015
    #19
  20. Offline
    Skarbone I would rather be snowboarding
    Explique surtout quel est le calcul que tu dois effectuer ;)
    Skarbone, 23 Janvier 2015
    #20