Durée rapportée incorrecte

Discussion dans 'Windows' créé par Elian, 30 Septembre 2004.

Statut de la discussion:
Fermée.
  1. Offline
    Elian Techno Mofo
    Equipe GamerZ.be
    Hello les gens. J'ai de temps en temps une vidéo ou l'autre dont la durée annoncée par le prog de lecture (j'ai testé avec WMP10, BSplayer et Zoomplayer) est fausse. Par exemple, j'ai souvent, pour des petites vidéos une durée de 2 secondes... donc la barre de temps avance jusque 2 secondes, là elle est au bout, mais la vidéo continue.

    Mais, plus chiant, j'ai aussi cela parfois avec des films. Pas pratique si on a envie d'aller voir la suite du film lorsqu'on ne sait pas aller plus loin qu'une demi heure par exemple et que le film fait 2h.

    Une idée ?

    exemple. Ici, la durée annoncée est de 11 secondes alors qu'en réalité, cela dure bien plus longtemps ;) et donc, la barre d'écoulement du temps est à fond, pas moyen de zapper plus loin.


    [IMG]
    Elian, 30 Septembre 2004
    #1
  2. Offline
    Paradis Obey, Buy, Consume
    En générale ce genre de problème peut survenir lorsque la vidéo ne contient pas assez de keyframe (image clef complete servant à recaler l'audio et la vidéo par la meme occasion), une solution, une ouverture sous virtualdub, avec ask for extended option dans le navigateur de fichier a ouvrir, un nouveau panneau s'ouvre une fois le fichier séléctionner, clicker re-derive keyframe. Là virtual dub travail un moment pour régénérer plus de keyframe a partir de la vidéo (normalement au moins 1/250 mais il arrive souvent sur le net du 1/500 1/700 ce qui pose plein de problème). Quand virtual dub aura fini d'ouvrir le fichier, il aura déjà calculer les images, il suffit de faire un direct stream copy en audio et en vidéo, save avi as....
    et roule ma poule le fichier généré est le même qu'au départ, juste avec plus de keyframe.

    P.S. : C'est pour la même raison que parfois les platines divx de salon ont du mal a lire des divx avec du son MP3/VBR, il faut qu'il y aie suffisamment de keyframe sinon décalage garanti.
    Paradis, 30 Septembre 2004
    #2
  3. Offline
    Jo_ m00
    Tu utilises ffdshow?

    Normalement il s'agit d'un bug lors de l' encodage...

    Je suppose que tu as ca qu'avec les mpegs (pas les avi).
    Jo_, 30 Septembre 2004
    #3
  4. Offline
    Elian Techno Mofo
    Equipe GamerZ.be
    Euuuh ouep ce sont les mpg qui foirent. J'vais bidouiller les deux films à ta sauce Paradis, on verra bien ;)
    Elian, 30 Septembre 2004
    #4
  5. Offline
    Paradis Obey, Buy, Consume
    hop, stop, pour les mpeg, rien n'est certain. La soluce c'étais pour les avi qui ont se problème. Si c'est du MPEG je crains que Bah n'aie pas tort....
    Paradis, 30 Septembre 2004
    #5
  6. Offline
    Elian Techno Mofo
    Equipe GamerZ.be
    Ah bein problème réglé, j'ai copié le film sur un cd griffé de part en part (me demande ce qui a pu lui arriver, ma soeur sans doute) et m'est impossible de le remettre sur mon hd, faudra que je le retrouve quelque part :D
    Elian, 30 Septembre 2004
    #6
  7. Offline
    Dark Jukka ex membre
    c'a ma deja fais ce genre de truc mais avec Cdex et ces quand j'encoder en mp3, il me marquait un temps de 1:30 min alors que le morceau faisait 3:30 min et lorsque je le mettat dans la platine mp3, le compteur de temps restait a zero.
    Dark Jukka, 1 Octobre 2004
    #7
  8. Offline
    tribal_ Elite
    j'ai aussi sa des fois mais avec un fichier .m2p (MPEG-4 rien que le son)

    Alors quand je test pour voir si tout c'est bien encodé je crois toujours içl est aps complet et alors je peut pas faire mon dvd

    ou bien j'ai sa mais avec *.m2v (MPEG-4 rien que video)

    mon film dure 1h30 et il me met qu'il dure 3h30

    alors apres 1h30 j'ai un ecran noir qui continue

    mais sa fait chier car o plus gros que le fichier est o plus de temps que je doit mettre en dvd
    tribal_, 1 Octobre 2004
    #8
Statut de la discussion:
Fermée.