Excel =recherchev !!???

Discussion dans 'Windows' créé par XOU_, 20 Décembre 2015.

  1. Offline
    XOU_ a TDK boy
    y0 !

    j'ai pas le résultat voulu, pourriez vous me corriger:

    J'ai 4 colonne dans la FEUILLE1 (A,B,C,D) ;
    dans la FEUILLE2, dans la cellule B1 j'ai la fonction suivante:

    Code:
    =recherchev(A1;'FEUILLE1'!A$1:D$800;2;"FAUX")
    le but étant que quand je tape dans la cellule de la colonne A, les cellules des colonnes B,C,D, se remplissent avec les valeurs de la FEUILLE1 correspondantes

    Je me fais comprendre?

    Le soucis:

    Prenons l'exemple suivant dans la FEUILLE1

    A1=18 B1=DUPONT C1=MICHEL D1=H

    A2=57 B2=DUPONT C2=SANDRA D2=F

    Dans la FEUILLE2 si je tape dans la cellule A5 par exemple la valeur 57, je devrais avoir: 57 DUPONT SANDRA F,...

    or j'obtiens 57 DUPONT MICHEL H

    J'ai constaté qu'il que quand je tombais sur un nom qui est repris plusieurs dans la liste, il continué avec les premières valeurs, et non en se référant on nombre indiqué dans la colonne A.

    Vous m'avez compris?
    XOU_, 20 Décembre 2015
    #1
  2. Offline
    Nikolas Cscup
    Cadeau :).. des années de casse-tête mais elle fonctionne...

    =SI(ESTERREUR(RECHERCHEV($A2;'FEUILLE1'!$A$2:$CL$800;COLONNE();FAUX));" ";RECHERCHEV($A2;'FEUILLE1'!$A$2:$CL$800;COLONNE();FAUX))
    Nikolas, 20 Décembre 2015
    #2
    lesaint9 et XOU_ aiment ça.
  3. Offline
    XOU_ a TDK boy
    nickel merci ! :)
    XOU_, 20 Décembre 2015
    #3
  4. Offline
    Nikolas Cscup
    Tu l as mis dans ton fichier excell?? ça fonctionne?
    Nikolas, 20 Décembre 2015
    #4
  5. Offline
    XOU_ a TDK boy
    Ouep j'ai modifié les données de ta formule et ca passe nickel (-:
    XOU_, 20 Décembre 2015
    #5
    Nikolas aime ça.