Le mystère d'IE ...

Discussion dans 'Web, design' créé par kaRma, 6 Novembre 2005.

Statut de la discussion:
Fermée.
  1. Offline
    kaRma Drink Fast Corp.
    Bonsouaaaaratous !

    Je viens de passer chez un pote qui utilise encore Internet Explorer chez lui (il en faut ...) et je voulais lui montrer mon blog.
    Et la, Oh mystère (!!!) Soucis !

    J'explique : dans ma dernière news, j'ai mis 3 images que 640*480 pixel.
    Sous Firefox : aucun problème, l'image est réduite et le menu apparait sur la droit comme prévu.

    Mais sur IE, devinez quoi ?
    Ca fouaaaar (ti punez !)
    En effet, l'image ne se redimensionne pas et cela a pour cause de virer mon menu (oué on aurait pu se dire qu'il aurait peté le layout, mais non meme pas, la, y a rien qui s'affiche ...)


    C'est un blog fait avec wordpress, je n'ai donc pas codé moi meme (de surcroit, j'en aurais été incapable...) et je ne comprends pas pourquoi d'un coté ca redimensionne et de l autre pas ... Si ca le fait d'un coté, c'est que y a un code qqpart qui lui dit de le faire ... j'imagine qu'il fait pas ca tout seul.
    Comment faire pour avoir une redimension des photos un peu grande dans internet explorer ?

    (je sais que j'ai qu'a redimensionner moi meme les photos, je le ferai si je ne trouve pas d'autre solution, mais j'aimerais comprendre et solutionner mon probleme)


    EDIT : Grand distrait dans l'ame j'ai omi l'adresse : www.mxv.be


    Merci d'avance pour votre aide
    kaRma, 6 Novembre 2005
    #1
  2. Offline
    jimP_ ex membre
    install lui firefox :p :roll:

    oké je sort :arrow:
    jimP_, 6 Novembre 2005
    #2
  3. Offline
    Arnoz Touriste
    Montre peut-être le blog pour qu'on voie la source. Moi j'ai aussi (eu) des soucis du genre et c'est toujours assez saoulant à régler, surtout le chipotage niveau CSS.
    Arnoz, 6 Novembre 2005
    #3
  4. Offline
    Fist Vieux Crouton
    Equipe GamerZ.be
    "Mon blog"

    il est dans sa signature
    Fist, 6 Novembre 2005
    #4
  5. Offline
    Arnoz Touriste
    Je pense pas que ce soit celui-là. Un il bugge pas et deux c'est pas un Wordpress.
    Arnoz, 6 Novembre 2005
    #5
  6. Offline
    eSb` That's Poker!
    http://www.mxv.be/

    Je présume que c'est celui là ;). Par contre, je ne sais pas t'aider.

    A part, réponse à la con... Pourquoi ne pas réduire tes photos à la base ?
    eSb`, 6 Novembre 2005
    #6
  7. Offline
    Loetheri Absent
    A cause de ceci :
    Code:
    p img {
    	padding: 0;
    	max-width: 100%;
    	}
    Pour etre précis, c'est le "max-width: 100%; qui n'est pas supporté par aucune version de IE.

    Ce n'est pas supporté par IE. Wiki.media-box.net
    Loetheri, 6 Novembre 2005
    #7
  8. Offline
    kaRma Drink Fast Corp.
    oui merci j'ai oublié de mettre l adresse con comme je suis ...


    Je sais changer ca moi meme tu crois ?
    kaRma, 6 Novembre 2005
    #8
  9. Online
    Esta Boy's dream
    Le seul moyen c'est une mise à jour d'IE, et , cette possibilité n'est qu'un rêve. IE ne sais pas lire quelques balises xHTML / CSS, etc

    Passe le sous firefox ou autre naviguateur actuel.
    Esta, 6 Novembre 2005
    #9
  10. Offline
    LifeNight Elite
    Très belle piscine :)
    LifeNight, 6 Novembre 2005
    #10
  11. Offline
    kaRma Drink Fast Corp.
    Mais je suis sur Firefox :p
    Mais en bon webmaster, je pense aux ignorants sur IE :D


    merchiiii jl'aime bien aussi :p

    (et ma tuture ? :D)
    kaRma, 6 Novembre 2005
    #11
  12. Offline
    Loetheri Absent
    Tu crois que si j'avais la balise directement sous la main, je l'aurais gardé pour moi ? Tu te trompes ... Seulement, voilà, il y a un problème pour le résoudre, il y a une solution : mettre toutes les images à une grandeur fixe. Et je pense que cela se résoudrait. Je n'ai aucune certitude de cela.

    Ceci dit, je donnes déjà une information. Cela aurait pu t'aider et cela peut encore aider d'autres personnes ...

    Je ne sais pas si tu me reproches quelque chose, mais si c'est le cas, redescends de ta lune.

    PS : Pour ce que tu devrais remplacer, tu peux essayer en mettant seulement "width" au lieu de "max-width", tout en gardant un 100%.
    Loetheri, 7 Novembre 2005
    #12
  13. Offline
    *Serval Elite
    Loetheri, je pense qu'il demandait simplement si c'était changeable dans le code (donc si il pouvait le faire lui) ;)

    Je peux voir ton css ?
    je n'ai jamais eu ce problème avec une image mais plusieures fois avec un bloc (je voulais qu'il descende jusqu'en bas de la page mais qu'il continue encore si il y avait plus de contenu pour que la page soit extensible :p)

    j'avais pour firefox un :
    Code:
    div#contenu 
    {
    	min-height: 100%;
    }
    et ca marchait nickel...

    pour IE, j'ai du utiliser un bug d'IE (comme quoi, parfois ca a du bon :p)
    et faire un
    Code:
    html { height: 100%; }
    body {	height: 100%;}
    * html #contenu { height: 100% } 
    
    car le *html n'est lu que par IE :p
    maintenant, ne me demande pas pourquoi c'est extensible, c'est justement la qu'est le bug :p

    Ca doit être faisable pour une photo, mais j'aurais besoin de ton CSS :)[/code]

    PS : ton site est down chez moi :? (ben oui, sinon je l'aurais récup tout seul ton css :p)
    *Serval, 8 Novembre 2005
    #13
  14. Offline
    deSir Peace & Love ;)
    site down chez moi aussi

    sinon pour ton pb de menu, chez moi avec ie, le menu de wordpress apparaissait en bas de page, et sous firefox l'image se reduisait correctement et le menu etait bien à sa place à droite
    deSir, 8 Novembre 2005
    #14
  15. Offline
    Arnoz Touriste
    J'ai un peu la même chose avec un header qui foire. Pour FF, je mets genre height: xxx px.
    Pour IE, je mets _height: xxx px. Car effectivement, le "_" est aussi lu que par IE.
    Arnoz, 8 Novembre 2005
    #15
Statut de la discussion:
Fermée.