probleme squid/squidguard

Discussion dans 'Windows' créé par Drogmapils, 28 Mai 2008.

Statut de la discussion:
Fermée.
  1. Offline
    Drogmapils No Futur
    Bonjour,


    J'ai installe un proxy avec webmin / squid + squidguard, je me retrouve sur la fin avec un probleme de droit a mes blacklists / destination groupe.

    Squid fait bel et bien son rôle.
    Si je n'utilise pas de blacklist / destination group, le reseau est dans le bon ACL.

    En resume, soit tout passe, soit rien.

    Dans mon squidguard.conf, l'erreur suivante apparait

    2008-05-28 12:32:29 [4113] New setting: dbhome: /var/lib/squidguard/db
    2008-05-28 12:32:29 [4113] New setting: logdir: /var/log/squid
    2008-05-28 12:32:29 [4113] init urllist /var/lib/squidguard/db/adult/urls
    2008-05-28 12:32:29 [4113] /var/lib/squidguard/db/adult/urls: Permission denied
    2008-05-28 12:32:29 [4113] going into emergency mode


    le repertoire en question

    -rwxrw---- 1 squid root 540145 mai 28 12:26 domains
    -rwxrw---- 1 squid root 1486848 mai 28 12:26 domains.db
    -rwxrw---- 1 squid root 796 mai 28 12:27 expressions
    -rwxrw---- 1 squid root 608406 mai 28 12:27 urls
    -rwxrw---- 1 squid root 888832 mai 28 12:28 urls.db


    (j'ai aussi teste en chown squid.squid mais l'effet est identique.)

    le chown a eu lieu a partir de /db.


    j'ai beau tout retourner, je ne trouve aucune solution pour ce probleme.

    la seule piste que j'ai, lors d'un ps -aux

    root 4105 0.0 0.1 10664 2184 ? Ss 12:32 0:00 squid -D
    squid 4107 0.1 0.4 14816 8640 ? S 12:32 0:01 (squid) -D
    squid 4109 0.0 0.0 7084 1836 ? Ss 12:32 0:00 (squidGuard) -c
    squid 4110 0.0 0.0 7084 1840 ? Ss 12:32 0:00 (squidGuard) -c
    squid 4111 0.0 0.0 7084 1840 ? Ss 12:32 0:00 (squidGuard) -c
    squid 4112 0.0 0.0 7084 1836 ? Ss 12:32 0:00 (squidGuard) -c
    squid 4113 0.0 0.0 7084 1840 ? Ss 12:32 0:00 (squidGuard) -c
    squid 4114 0.0 0.0 3232 688 ? Ss 12:32 0:00 (unlinkd)



    je contaste que le 1er "Squid -D" est lance par le root et non squid mais je n'ai aucune idée comment le forcer a le lancer en tant que "squid".

    dans squid.conf, les lignes suivantes apparaissent (teste avec et sans)

    cache_effective_user squid
    cache_effective_group squid


    je suis sur une fedora 9... j'ai pas installe ipcop car il reconnaissait pas le matos le petiot :beuh:

    Merci d'avance pour une solution ou meme une idée de solution


    ps : je suis pas un pro de linux... j'ai commence fin de semaine derniere :p
    Drogmapils, 28 Mai 2008
    #1
  2. Offline
    ozilrit Touriste
    root est nécessaire pour utiliser un port inférieur à 1024. Ce n'est donc peut-être pas illogique.
    ozilrit, 28 Mai 2008
    #2
  3. Offline
    Drogmapils No Futur

    ah oui juste

    donc ne viendrait pas de la :-(
    Drogmapils, 28 Mai 2008
    #3
  4. Offline
    ozilrit Touriste
    Essaie :
    su - squid -c `tail /var/lib/squidguard/db/adult/urls`
    ozilrit, 28 Mai 2008
    #4
  5. Offline
    Drogmapils No Futur


    en copy/paste de ta command

    This account is currently not available.
    Drogmapils, 28 Mai 2008
    #5
  6. Offline
    ozilrit Touriste
    Mmmmh, aucun shell n'est assigné à squid peut-être ?

    grep squid /etc/passwd
    ozilrit, 28 Mai 2008
    #6
  7. Offline
    Drogmapils No Futur

    je n'ai pas touche a ce compte.

    fedora et squid installaient, le compte etait là.

    squid /etc/passwd
    squid:x:23:23::/var/spool/squid:/sbin/nologin
    Drogmapils, 28 Mai 2008
    #7
  8. Offline
    ozilrit Touriste
    usermod -s /bin/sh squid

    et réessaie.
    ozilrit, 28 Mai 2008
    #8
  9. Offline
    Drogmapils No Futur
    la command est bien passe mais toujours le meme resultat


    2008-05-28 14:24:11 [2148] /var/lib/squidguard/db/adult/urls: Permission denied
    2008-05-28 14:24:11 [2148] going into emergency mode


    j'ai relance squid manuellement => rien
    init 6 => rien
    Drogmapils, 28 Mai 2008
    #9
  10. Offline
    Drogmapils No Futur


    si ça peut avancer

    j'ai refais cette commande et j'obtiens maintenant

    su - squid -c `tail /var/lib/squidguard/db/adult/urls`
    ztik.com/x/cok/sam01: zpornos.com/anal: Aucun fichier ou dossier de ce type
    Drogmapils, 28 Mai 2008
    #10
  11. Offline
    Nmy Touriste
    ah mon avis tu revoir tout tes liens ds la package blacklist.....

    je pense qu il fait reference a des dossiers contenant les regex pour bloquer certains sites mais apparemment tu n as pas les dossiers ds ton architecture....
    Nmy, 28 Mai 2008
    #11
  12. Offline
    Drogmapils No Futur


    si j'ouvre le fichier cible ( /var/lib/squidguard/db/adult/urls), j'obtiens la liste d'url.


    j'ai teste de creer ma propre liste

    -rwxrw---- 1 squid squid 29 mai 28 15:08 Test.desturllist
    -rwxrw---- 1 squid squid 8192 mai 28 15:08 Test.desturllist.db


    et toujours

    2008-05-28 15:15:02 [3592] New setting: dbhome: /var/lib/squidguard/db
    2008-05-28 15:15:02 [3592] New setting: logdir: /var/log/squid
    2008-05-28 15:15:02 [3592] init urllist /var/lib/squidguard/db/Test.desturllist
    2008-05-28 15:15:02 [3592] /var/lib/squidguard/db/Test.desturllist: Permission denied
    2008-05-28 15:15:02 [3592] going into emergency mode
    Drogmapils, 28 Mai 2008
    #12
  13. Offline
    Drogmapils No Futur
    Bon bhein voilà, la config devait etre ok depuis longtemps... le probleme, un autre programme qui empechait l'user "squid" de chipoter a ces fichiers...

    je suis parti et tout avait l'air de fonctionner


    Merci à vous 2 ;)
    Drogmapils, 28 Mai 2008
    #13
  14. Offline
    Nmy Touriste
    de rien n hesite pas meme si on a pas vrmt trouver la solution
    Nmy, 30 Mai 2008
    #14
Statut de la discussion:
Fermée.