Streaming > Barre de progression.

Discussion dans 'Web, design' créé par 0megear, 22 Juillet 2005.

Statut de la discussion:
Fermée.
  1. Offline
    0megear CHAROGNARD
    Enfaite voila.
    J'ai un fichier vidéo (avi) dont j'ai fait un streaming !

    Voici le code de ma page :

    Code:
    <embed src="Test.avi" width="640" height="480" type="video/msvideo" autostart="true">
    
    Le probleme c'est que le fichier fait 70Méga... Et qu'on ne voit pas de barre de progression du buffering :p
    Comment faire pour que cette barre apparaisse ? :p
    0megear, 22 Juillet 2005
    #1
  2. Offline
    PiaFlalCoOl NiuAge
    Désolé connais pas la réponse mais je te conseille de préciser aux visiteurs la taille du fichier. 70 Mo en streaming, c'est pas tres conseillé je pense.
    PiaFlalCoOl, 22 Juillet 2005
    #2
  3. Offline
    La Poubelle Elite
    Si c'est du streaming, la video est lue en direct et le client ne reçoit pas l'entiereté du fichier
    La Poubelle, 22 Juillet 2005
    #3
  4. Offline
    Xou I ♥ rien
    Ici tout ce que tu vas faire, c'est que l'utilisateur va lire le contenu tout en téléchargeant, un peu comme le fait flash en fait.
    Même avant d'avoir tout téléchargé, celui ci va commencer la lecture du fichier.
    Un streaming, c'est une partie d'un media qui est envoyé mais qui ne figurera jamais sur le disque dur, sauf, si tu utilises divers softs de rippage.
    De plus, il te faut un serveur capable de faire du streaming :p
    Xou, 22 Juillet 2005
    #4
  5. Offline
    0megear CHAROGNARD
    :p
    0megear, 22 Juillet 2005
    #5
  6. Offline
    Spo0n Dr. Gonzo
    Code:
    <object id="NSPlay" classid="CLSID:22d6f312-b0f6-11d0-94ab-0080c74c7e95" 
    codebase="http://www.microsoft.com/netshow/download/en/nsasfinf.cab#Version=2,0,0,912" 
    viewastext=""  width="640" height="480">
    <param name="ControlType" value="1">
    <param name="filename" value="Test.avi">
    <param name="AutoStart" value="true">
    <param name="AnimationStart" value="true">
    <param name="TransparentAtStart" value="false">
    <param name="ShowControls" value="false">
    <PARAM NAME="ShowStatusBar" VALUE="True">
     <!--NETSCAPE PLUG-IN STARTS HERE-->
    <embed src="Test.avi" type="application/x-mplayer2" Displaysize="4" autostart="1" enabled="1" showstatusbar="1" showdisplay="0" showcontrols="0" pluginspage="http://www.microsoft.com/Windows/MediaPlayer/" CODEBASE="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,0,0,0" width="640" height="480"></embed>
     </object>
    Spo0n, 22 Juillet 2005
    #6
  7. Offline
    0megear CHAROGNARD
    Merci, j'essaie ;P

    Edit : Il y a bien le "connexion en cours".
    Mais bon, ca prend du temps et il lance la vidéo uniquement quand il l'a chargé entierement :pfiou:


    Edit2 : Je vais le convertir en wmv pour le streaming :p
    0megear, 22 Juillet 2005
    #7
Statut de la discussion:
Fermée.