Wifi radar, comment l'installer ?

Discussion dans 'Windows' créé par GUMBAL, 8 Octobre 2006.

Statut de la discussion:
Fermée.
  1. Offline
    GUMBAL 1337
    Bonjour à tous,

    J'aimerais installer Wifi radar 1.9.6 mais malheureusement je dois mal m'y prendre, je n'y parvient donc pas du tout, si qqun peut m'expliquer en gros, j'essaye pourtant d'installer comme il est dit sur le net.

    Merci pour votre future aide \o/

    Edit : voici comment j'ai procédé :

    Code:
     # sudo nano /etc/apt/sources.list  
    
    A la fin du fichier j'ai ajouté :
    
      deb http://fr.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
    
    et enregistré, puis tappé :
    
        [b]# sudo apt-get update[/b]
    
      [b]# sudo apt-get install wifi[/b]
    
    
    Résultat :

    Code:
    gumbal13@X13:~$ sudo apt-get install wifi-radar
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances... Fait
    E: Impossible de trouver le paquet wifi-radar
    gumbal13@X13:~$
    GUMBAL, 8 Octobre 2006
    #1
  2. Offline
    grosnours ex membre
    apt-cache search radar
    grosnours, 8 Octobre 2006
    #2
  3. Offline
    GUMBAL 1337
    mais il m'affiche que cela alors

    gumbal13@X13:~$ apt-cache search radar
    gumbal13@X13:~$

    rien de plus
    GUMBAL, 8 Octobre 2006
    #3
  4. Offline
    grosnours ex membre
    Ceci explique celà. Sur une EdgyEft j'ai:
    A mon avis, il te manque quelques repos. Décommente toutes les lignes commençant par "deb" dans le fichier /etc/apt/sources.list .

    Le mien (toujours pour edgy) ressemble à:
    grosnours, 8 Octobre 2006
    #4
  5. Offline
    GUMBAL 1337
    merci je vais essayer (je m'y connais absolument pas, voila pourquoi je galere un peux =D)
    GUMBAL, 8 Octobre 2006
    #5
  6. Offline
    Calvin80 Elite
    Gumbal, qques petits truc à savoir sur 'apt':

    -> apt-cache search nom_package : te permet de voir si un paquet est dispo sur les sources présentes dans /etc/apt/source.list

    -> apt-get update: mettre a jour les paquets dispo (si on ajoute une nvelle source par exemple, c'est necessaire !)

    -> apt-cache show nom_package: affiche la description d'un paquet

    -> apt-cache policy nom_package: affiche la version nstallée et la version disponible du paquet.

    Cordialement.
    Calvin80, 8 Octobre 2006
    #6
  7. Offline
    GUMBAL 1337
    merci bien


    En fait, je pense qu'ou je bloque, c'est lorsque j'ai les divers logiciels, par exemple

    install_flash_player_7_linx
    ou
    wifi-radar-1.9.6

    qui sont tout deux, des répértoires avec des fichiers dedans (les deux répértoires cités ci-dessus sont sur mon bureau pour le moment, je suppose que je dois pas les placer à cet endroit afin de les installer par la commande sudo apt-get install nom_fichier ? (et aussi, je tape la commande sudo ap-get install (suivit du nom du fichier) mais par exemple : wifi-radar-1.9.6 ou le nom d'un des fichiers présent dans le répértoire ?)

    Je cherche sur le net, mais je trouve pas vrmt la réponse à ce que je veux, et apparamant, le forum ubuntu francais ne fonctionne plus pour l'instant
    GUMBAL, 8 Octobre 2006
    #7
  8. Offline
    grosnours ex membre
    Euh what ?

    Avec la commande "apt-get install", tu n'as rien à faire à la main, le gestionnaire de pkg (en gros: l'OS) s'occupe de tout.

    Si tu veux absolument une autre version ou un pkg qui n'existe pas pour ta distrib, tu dois télécharger les sources et les compiler, mais ça n'est pas le cas pour wifi-radar.
    grosnours, 8 Octobre 2006
    #8
  9. Offline
    GUMBAL 1337
    donc je tape

    apt-get install wifi-radar-1.9.6 ?

    Et je place d'abord où wifi radar avant de faire apt-get install ?

    merci : )
    GUMBAL, 8 Octobre 2006
    #9
  10. Offline
    grosnours ex membre
    Tu places rien du tout nulle part !

    Quand tu tapes "apt-get update", tu mets à jour la liste des pkg disponibles pour ta distrib (c'est un peu comme windoz update mais pour tous les programmes, installés ou disponibles).

    Quand tu tapes "apt-cache search quelquechose", ca cherche "quelquechose" dans la grosse liste des applications qui peuvent être installées. Jvais comparer ça à une recherche sur télécharger.com parce que je ne vois pas d'équivalent sous windoz :)

    En supposant que l'application "quelquechose" existe, quand tu tapes "apt-get install quelquechose", l'OS (le gestionnaire de pkg plus précisément) va télécharger le pkg en question et l'installer. Compare ça à l'installation d'une application sous windoz, malgré que ce soit plus complexe (gestion des dépendances, mises à jour automatiques, etc).

    Donc dans ton cas:
    1)Tu vérifies bien que "wifi-radar" est bien disponible (apt-cache search wifi-radar).
    2) S'il l'est, tu tapes "apt-get install wifi-radar".
    3) S'il ne l'est pas, tu édites le fichier (/etc/apt/sources.list) qui recense les sites où tu peux te fournir en pkg (et tu y décommentes les lignes commençant par "deb" ou "debquelquechose"). Tu mets à jour la liste des pkg disponibles et tu recommences en 1).


    Quand un pkg est disponible (donc que tu le vois avec "apt-cache search"), à moins d'avoir une excellente raison (tu veux une version différente, tu veux appliquer un patch, etc), tu l'installes betement sans rien faire d'autre "apt-get install brol".
    grosnours, 8 Octobre 2006
    #10
  11. Offline
    Calvin80 Elite
    LOL ;)

    dur de perdre les habitudes win$ hein ?
    comme l'as bien dit grosnounours, les paquets (programmes) sont hébergés sur des "serveurs de paquets" et la commande 'apt' te permet d'installer automatiquement les paquets que tu veux.
    L'installation passer d'abord par un telechargement du paquet, puis par son installation (et optionnellement par sa configuration)

    Quelques info pour Gumbal :
    apt te permet d'installer directement les paquets depuis un serveur de paquet.
    Cependant, il peut arriver que tu telecharges les sources d'un programme, soit parce qu'il n'existe pas de paquet, ou alors parce que tu veux absolument la derniere version.
    Si c'est le cas, il te faut telecharger les sources, aller dans le repertoire ou tu les as placées et faire:
    ./configure
    make
    sudo make install

    dans 75% des cas, ceci te permets d'installer un programme 'depuis ses sources'
    ./configure : etape de configuration avant compilation
    ./make: compilation du programme et creation des binaires
    sudo make install: installation des binaires et des fichiers de config

    J'espere que ça pourra t'aider.
    Calvin80, 8 Octobre 2006
    #11
  12. Offline
    GUMBAL 1337
    Code:
    agumbal13@X13:~$ apt-cache search wifi-radar
    gumbal13@X13:~$ apt-cache search wifi
    linux-restricted-modules-2.6.15-23-386 - Non-free Linux 2.6.15 modules on 386
    linux-restricted-modules-2.6.15-23-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
    linux-restricted-modules-2.6.15-23-k7 - Non-free Linux 2.6.15 modules on AMD K7
    linux-restricted-modules-2.6.15-25-386 - Non-free Linux 2.6.15 modules on 386
    linux-restricted-modules-2.6.15-25-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
    linux-restricted-modules-2.6.15-25-k7 - Non-free Linux 2.6.15 modules on AMD K7
    linux-restricted-modules-2.6.15-26-386 - Non-free Linux 2.6.15 modules on 386
    linux-restricted-modules-2.6.15-26-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
    linux-restricted-modules-2.6.15-26-k7 - Non-free Linux 2.6.15 modules on AMD K7
    linux-restricted-modules-2.6.15-27-386 - Non-free Linux 2.6.15 modules on 386
    linux-restricted-modules-2.6.15-27-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
    linux-restricted-modules-2.6.15-27-k7 - Non-free Linux 2.6.15 modules on AMD K7
    gumbal13@X13:~$
    
    avec wifi-radar rien, avec wifi si, mais je suppose qui a rien de ce que je cherche dedans : p
    Par contre je comprends plus à partir de ce moment la

    la je suis pommer en plus le wifi oet le forum de chez ubuntu sont encore down, tout a l'heure il fonctionnait en plus : (

    et sinon j'ai ausis cela :

    Code:
    root@X13:~# grep deb /etc/apt/sources.list
    deb http://be.archive.ubuntu.com/ubuntu/ dapper main restricted
    deb-src http://be.archive.ubuntu.com/ubuntu/ dapper main restricted
    deb http://be.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
    deb-src http://be.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
    # deb http://be.archive.ubuntu.com/ubuntu/ dapper universe
    # deb-src http://be.archive.ubuntu.com/ubuntu/ dapper universe
    # deb http://be.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
    # deb-src http://be.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
    deb http://security.ubuntu.com/ubuntu dapper-security main restricted
    deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
    # deb http://security.ubuntu.com/ubuntu dapper-security universe
    # deb-src http://security.ubuntu.com/ubuntu dapper-security universe
    deb http://fr:archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
    root@X13:~#
    
    GUMBAL, 8 Octobre 2006
    #12
  13. Offline
    GUMBAL 1337
    en effet Calvin, pas facile : D

    je lis cela et j'essaye : )
    GUMBAL, 8 Octobre 2006
    #13
  14. Offline
    Calvin80 Elite
    Gumbal:

    voici mon /etc/apt/sources.list
    Code:
    ## Add comments (##) in front of any line to remove it from being checked.
    ## Use the following sources.list at your own risk.
    
    deb http://archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
    
    ## MAJOR BUG FIX UPDATES produced after the final release
    deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
    
    ## UBUNTU SECURITY UPDATES
    deb http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
    deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
    
    ## BACKPORTS REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
    deb http://archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
    deb-src http://archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
    
    ## PLF REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
    deb http://packages.freecontrib.org/plf dapper free non-free
    deb-src http://packages.freecontrib.org/plf dapper free non-free
    
    ## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
    ## servers. RealPlayer10, Opera and more to come.)
    deb http://archive.canonical.com/ubuntu dapper-commercial main
    
    
    voici le paquet "wifi-radar"
    Code:
    root@dwartel-laptop:/home/dwartel# apt-cache policy wifi-radar
    wifi-radar:
      Installed: (none)
      Candidate: 1.9.6-0ubuntu4
      Version table:
         1.9.6-0ubuntu4 0
            500 http://archive.ubuntu.com dapper/universe Packages
    
    PS: wifi-radar est juste un utilistaire: il est presque aussi simple de configurer à la main via iwconfig
    Calvin80, 8 Octobre 2006
    #14
  15. Offline
    Phoen1X Elite
    oui mais il est vrai qu'il est tres pratique,

    utilise les sources proposée ensuite

    sudo apt-get install wifi-radar

    et plus de problème

    (J'ai lu le post en diagonale.)
    Phoen1X, 8 Octobre 2006
    #15
  16. Offline
    grosnours ex membre
    Le voilà le problème.
    Cherche un peu la signification des différents noms de repos (main, restricted, universe, multiverse, etc) et tu comprendras le comment du "pourquoi wifi-radar il est pas dans la liste des pkg ?!".
    Ubuntu n'étant vraiment pas ma distrib préférée, jai jamais cherché à comprendre "pourquoi".

    D'après la commande que Calvin colle, le pkg wifi-radar est dans le repo "universe". Et dans ton sources.list, il n'y figure pas (en fait si, mais il est commenté, donc non).

    Décommente (vire le # devant) toutes les lignes que tu as cité, lance "apt-get update" et tu pourras installer wifi-radar (et plein d'autres apps sans doute).


    PS: je soupçonne ces crétins d'Ubuntu d'avoir la même vision utopiste que les debianistes ... et je crois que c'est pour ça qu'ils ont séparé les repos en fonction des licenses sous lesquelles sont édités les pkg ...
    grosnours, 9 Octobre 2006
    #16
  17. Offline
    grosnours ex membre
    Ah oui, je crois qu'il y a un truc graphique pour gérer les pkg, mais je ne l'ai jamais cherché.
    T'auras surement plus facile avec ça qu'avec la console :)
    grosnours, 9 Octobre 2006
    #17
  18. Offline
    ImMorT4L Touriste
    Quand je vois tout ce trucmuch pour installer un programme... Je me dis que ma Gentoo est tout compte fait vraiment pas si compliquée que ça :gne:
    ImMorT4L, 10 Octobre 2006
    #18
  19. Offline
    GUMBAL 1337
    non c'est bon, en deux comandes, j'ai pu installer les logiciels que je voulais : )

    merci grosnours et Calvin
    GUMBAL, 10 Octobre 2006
    #19
Statut de la discussion:
Fermée.