Activer les addresses ut2004:// sur Windows !

Discussion dans 'Action, Shooters' créé par Carambar, 12 Février 2004.

Statut de la discussion:
Fermée.
  1. Offline
    Carambar He once forgot how to cry
    Il semblerais que Epic a survolé un léger petit détail dans son empressement pour sortir la démo :p . Il apparais que le nouveau protocol url (ut2004) n'est pas activé lorsqu'on installe la démo de UT2004. Pour rémédier à ce problème, effectuez la procédure suivante :

    - Collez ce qui suis dans un fichier txt.
    - Editez les chemins pour les adapter à votre environnement.
    - Change l'extension de fichier en reg.
    - Double cliquez pour l'importer dans la base de registre (ne marche que sous 2000/XP).

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\ut2004]
    @="URL:Unreal Protocol"
    "URL protocol"=""
    
    [HKEY_CLASSES_ROOT\ut2004\DefaultIcon]
    @="c:\\UT2004demo\\System\\Unreal.ico"
    
    [HKEY_CLASSES_ROOT\ut2004\Shell]
    @="open"
    
    [HKEY_CLASSES_ROOT\ut2004\Shell\open]
    @="&Play this Unreal level"
    
    [HKEY_CLASSES_ROOT\ut2004\Shell\open\command]
    @="c:\\UT2004demo\\System\\UT2004.exe \"%1\""
    Vous pouvez tester avec le lien suivant :

    ut2004://62.131.17.67/
    Carambar, 12 Février 2004
    #1
  2. Offline
    KraiS Elite
    ... heu, ça veut dire ke si on fait pas ça y'a pas moyen de se connecter à un IP, ou ke le jeu se lance pas automatiquement en cliquant sur un url ut2k4?

    G testé hier soir (cette nuit koi), je trouve le jeu trop amusant, c bo, gg les véhicules, ça pete bien... :D
    ...mais g pas réussi à me connecter, ni a avoir une liste de serveurs..? :-(

    G des chtites questions aussi ki me turlupine:
    - Je n'ai pas trouvé d'endroit ou on peut changer ses commandes (avancer, reculer,...). Celles d'origine me conviennent mais bon... j'aimerais savoir si...

    - Pour le rendu 3D, il m'affiche le Direct 3D mais apparemment pas l'Open GL...?

    - Eske y'a moyen d'avoir des serveurs ut2k4 avec The All-seeing Eye v2.3, pask'il est pas dans la liste des jeu..?

    t sur ke ça marche pas avec w98se?
    Un .reg ça va d'office dans le registre y me semble..
    sinon, comment je fais sous w98?
    KraiS, 12 Février 2004
    #2
  3. Offline
    Carambar He once forgot how to cry
    Ca veut dire que les liens du style ut2004:// ne fonctionnent pas pour l'instant.

    Hmm, aurais-tu un firewall par hazard ? La démo va chercher la liste sur le serveur maître.

    207.135.145.6
    Port 28902
    TCP en sortie

    212.42.16.85
    Port 27001
    UDP en entrée

    212.42.16.86
    Port 27001
    UDP en sortie

    C'est vrai que c'est pas évident pour trouver l'écran qui fais ca ;) . Va dans Settings : Input puis clique sur Configure Controls.

    http://users.pandora.be/byeclan/UT2003FAQ/tweaksandfixes-d3dvsopengl.htm

    Dans UT2004.ini (utilise le bloc notes), décommente la ligne suivante de la manière suivante. Ca devrais activer l'option OpenGL.

    Code:
    [Engine.Engine]
    RenderDevice=D3DDrv.D3DRenderDevice
    ;RenderDevice=D3D9Drv.D3D9RenderDevice
    ;RenderDevice=Engine.NullRenderDevice
    ;RenderDevice=OpenGLDrv.OpenGLRenderDevice
    Code:
    [Engine.Engine]
    RenderDevice=D3DDrv.D3DRenderDevice
    ;RenderDevice=D3D9Drv.D3D9RenderDevice
    ;RenderDevice=Engine.NullRenderDevice
    RenderDevice=OpenGLDrv.OpenGLRenderDevice
    Normalement, UT2004 utilise un protocole similaire si pas identique à UT2003 mais il se peut qu'il faudras une mise-à-jour de ASE pour accomoder d'éventuels changements.

    En fait, l'astuce que j'ai posté constitue un fichier d'importation pour 2000/XP (RegEdit 5). Il faudrais créer une un fichier reg qui est compatible avec la base de registre w9x. Je vais demander à quelqu'un de faire ca.
    Carambar, 12 Février 2004
    #3
  4. Offline
    henkin Touriste
    j ai teste avec ton lien et ce me donne une page blanche :/
    henkin, 12 Février 2004
    #4
  5. Offline
    Carambar He once forgot how to cry
    C'est parceque phpBB la transforme en ca :

    http://ut2004://62.131.17.67/

    Tape l'addresse en elle même dans la barre d'addresse de ton navigateur web et ca devrais marcher :p .

    ut2004://62.131.17.67/

    P.S: L'OpenGL ne semble pas fonctionner :/ .
    Carambar, 12 Février 2004
    #5
  6. Offline
    henkin Touriste
    Voilà qui est mieux ;).
    henkin, 12 Février 2004
    #6
  7. Offline
    KraiS Elite
    Merci pour ces réponses éclairantes, Grand Xan... :D


    ... g un firewall mais j'ai donné l'accès pour ut2k4... v essayer sans...
    KraiS, 13 Février 2004
    #7
Statut de la discussion:
Fermée.