Aide pour découpe css

Discussion dans 'Web, design' créé par vitAl, 30 Novembre 2005.

Statut de la discussion:
Fermée.
  1. Offline
    vitAl GamerZ2008
    J'ai réalisé une découpe simpliste en css (c'est la première fois que je découpe un site de cette manière). Malheureusement même aussi simple, j'ai un problème : dans ma partie générale, celle qui est réservée pour le contenu de la page (et nommée à ce titre .contenu), si j'ai un tableau trop grand, il se retrouve décallé vers le bas de page (en dessous des 100% de .menu en fait mais toujours avec la marge a gauche que j'ai spécifié dans .contenu).

    Si quelqu'un a une solution pour que le tableau s'affiche "normalement" dans la partie .contenu même s'il est très grand, je suis preneur merci.

    Voici un extrait du code .css qui reprend les différentes coupes que j'ai faites.

    Merci!

    Code:
    
    #header1 {
    background-color: #C70452;
    width: 100%;
    height: 75px;
    }
    
    #titre {
    font-size: 45px;
    color: white;
    font-weight: bold;
    margin-left: 30px;
    margin-top: 0px;
    padding: 10px;
    }
    
    #logo {
    float: left;
    margin-left: 0px;
    }
    
    #header2 {
    background-color: #336699;
    width: 100%;
    height: 20px;
    }
    
    .rubriques {
    float: right;
    margin-right: 20px;
    margin-top: 5px;
    }
    
    .menu {
    float: left;
    background-color: #336699;
    width: 200px;
    height: 100%;
    }
    
    .contenu {
    margin-left: 210px;
    width: 780px;
    text-align: justify;
    }
    
    vitAl, 30 Novembre 2005
    #1
  2. Offline
    aKC1a OldSchool CS Star
    un pti lien en ligne ?
    pcq g rien compris :-(
    aKC1a, 1 Décembre 2005
    #2
  3. Offline
    The Shaman Elite
    The Shaman, 1 Décembre 2005
    #3
  4. Offline
    vitAl GamerZ2008
    http://membres.lycos.fr/patricephp/tab.php

    A noter que je viens de remarquer qu'avec Firefox, le tableau se place au bon endroit. Mais avec IE le tableau commence quand mon menu s'achève sans que je comprenne pourquoi.
    vitAl, 1 Décembre 2005
    #4
  5. Offline
    spinerz Touriste
  6. Offline
    vitAl GamerZ2008
    Je ne pense pas que ça puisse m'aider à part rendre le tableau plus beau...
    Et ça ben ça sera pour quand ça marchera correctement.
    vitAl, 1 Décembre 2005
    #6
  7. Offline
    aKC1a OldSchool CS Star
    Code:
    .menu {
    	float: left;
    	position: absolute;
    	background-color: #336699;
    	width: 200px;
    	height: 100%;
    	top: 110;
    	left: 10;
    } 
    
    ca devrait marcher :)

    mais please soigne ton code et cherche un hébergeur autre que lycos pour faire des test ya rien de plus incompatible :)
    aKC1a, 1 Décembre 2005
    #7
  8. Offline
    spinerz Touriste
    spinerz, 1 Décembre 2005
    #8
  9. Offline
    vitAl GamerZ2008
    Merci aKC1a!

    Pour le code c'est totalement vrai mais je suis un peu dans l'urgence lol. Je ferai mieux la prochaine fois ;).

    En fait ça marche encore mieux avec top=95 et left=0 niveau mise en page ;).

    Encore merci!
    vitAl, 1 Décembre 2005
    #9
  10. Offline
    aKC1a OldSchool CS Star
    à ton service :)
    aKC1a, 1 Décembre 2005
    #10
Statut de la discussion:
Fermée.