bas du site = bas de page.

Discussion dans 'Web, design' créé par PiaFlalCoOl, 29 Avril 2005.

Statut de la discussion:
Fermée.
  1. Offline
    PiaFlalCoOl NiuAge
    :arrow: Le site problématique

    Vous remarquez sur cette page que le bas du design ne touche pas le bas de la page. Et c'est vraiment laid.

    Donc comment je fais pour que ce problème soit réglé ? (sans utiliser de CSS plzz car sur cett page toute simple, je pourrais peut être le faire en CSS, mais sur le reste du site, y'a le même problème et je pourrais pas coder toute les pages en CSS).

    Regardez le code de la page.
    En fait, c'est l'image background.gif qui est est le background d'une cellule.

    :arrow: un truc important : quand je regarde le site sur le disque dur, y'a pas ce problème, mais sur internet, ça chie.

    Et dernier truc, le site s'ajuste bien à la taille de la page, mais y'a quand même toujours ce problème de bas de page...

    THX
    PiaFlalCoOl, 29 Avril 2005
    #1
  2. Offline
    guslinux Gamerz'ien
    je capte pas, le bg va bien jusque en bas pourtant ...

    'fin => enleves la 1e ligne "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">"
    guslinux, 29 Avril 2005
    #2
  3. Offline
    John__ Touriste
    perso je sait pas

    mais j'm bcp le site !
    John__, 29 Avril 2005
    #3
  4. Offline
    Xou I ♥ rien
    Code:
    leftMargin=0 link=#f2f2f2 
    onload="MM_preloadImages('images/over.gif')" text=#f2f2f2 
    topMargin=0 vLink=#f2f2f2 marginheight="0" marginwidth="0"
    y'a tout sauf -> bottommargin ou qqch, le tag html exacte je m'en souviens plus, CSS -> mais tu peux rajouter ds la balise body :
    Code:
    style="margin:0px;"
    Normalement ça devrait marcher :)

    Je viens de matter la page sous firefox, et la page foire un coup :oops:
    Xou, 29 Avril 2005
    #4
  5. Offline
    (c'est de toi?! Tin, tu t'es vachement amélioré! :shock:)
    Gee_oldd, 29 Avril 2005
    #5
  6. Offline
    KraiS Elite
    faut ke tu mettes ton image de fond dans ton body

    Code:
    <body background="images/background.gif" ....>
    j'crois pas ke ça existe pas le bottommargin
    KraiS, 29 Avril 2005
    #6
  7. Offline
    PiaFlalCoOl NiuAge
    @ guslinux : ah bon ? les 2 "colonnes" vont bien jusqu'en bas ?? pas chez moi...

    @Gouwii : ouai, c'est de moi ! content que ça te plaise. Et heureusement que je m'améliore hehe

    @ Krais : je peux pas la mettre dans le body, parce que si je fais ça, l'image va se répéter, vu que je ne peux pas la centrer, je pense que ça n'ira pas.

    @ Xyo, qu est ce qui foire sous firefox ?? plzz
    PiaFlalCoOl, 29 Avril 2005
    #7
  8. Offline
    PiaFlalCoOl NiuAge
    ah ouai, je viens de regarder avec Firefox, ça chie à mort !!

    Quelqu'un a une explication... ?? plzz
    PiaFlalCoOl, 29 Avril 2005
    #8
  9. Offline
    Xou I ♥ rien
    Je regarderai plus amplement chez moi parce que là, suis un petit peu au cours et euh, c'est chaud :D
    Xou, 29 Avril 2005
    #9
  10. Offline
    pyngu Touriste
    J'ai l'impression que ça foire à cause des ascenseur, le décalage entre ton texte et les colonnes correspond juste à cette largeur.

    Par contre pour le site ça pose pas de problème, la page est niquel.
    pyngu, 29 Avril 2005
    #10
  11. Offline
    RedCross ex membre
    Les scripts Voila qui rajoutent automatiquement en bas de page foutent de l'espace.

    Et puis, sur FireFox, ça décale.
    RedCross, 29 Avril 2005
    #11
  12. Offline
    PiaFlalCoOl NiuAge
    ah ok, ça viens de voila... thx vais les supprimer si je peux, je sais pas comment ça marche.

    Et Redcross, t'aurais pas une idée d'ou viens le blème sous Firefox ?

    thx all.
    PiaFlalCoOl, 29 Avril 2005
    #12
  13. Offline
    PiaFlalCoOl NiuAge
    Je viens de regarder, t'as raison, y'a des script voila, et impossible de les virer... donc vivement que j'ai mon nouvel hébergeur...

    Mais par contre, faut que je trouve ce qui va pas sous FF.
    PiaFlalCoOl, 29 Avril 2005
    #13
  14. Offline
    eLneciO Elite
    J'avais un peu de temps à perdre alors j'ai vite codé ca :
    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title>\Fan Art Project/</title>
    <script type="text/javascript">
    <!--
    function MM_preloadImages() { //v3.0
      var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
        var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
        if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
    }
    
    function MM_swapImgRestore() { //v3.0
      var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
    }
    
    function MM_findObj(n, d) { //v4.01
      var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
        d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
      if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
      for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
      if(!x && d.getElementById) x=d.getElementById(n); return x;
    }
    
    function MM_swapImage() { //v3.0
      var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
       if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
    }
    //-->
    </script>
    <style>
    body {
    background-color:#877867;
    background-image:url(images/background.gif);
    background-position:center;
    background-repeat:repeat-y;
    margin:0;
    }
    #global{
    width:252px;
    margin:0 auto 0 auto;
    }
    </style>
    </head>
    
    <body>
    <div id="global">
     <img src="images/main.gif" height="214" width="252">
     <br>
     <a href="http://pagesperso.laposte.net/dllimage/fanart/index.html" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('enter','','images/over.gif',1)" target="hidden">
      <img src="images/enter.gif" width="252" height="10" alt="ENTER" border="0" name="enter">
     </a>
     <br>
     <img src="images/sec.gif" width="252" height="48">
    </div>
    </body>
    </html>
    chez moi ça fonctionne sur firefox et sur ie
    eLneciO, 29 Avril 2005
    #14
  15. Offline
    Xou I ♥ rien
    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD><TITLE>\Fan Art Project/</TITLE>
    <META content="text/html; charset=iso-8859-1" http-equiv=Content-Type>
    <SCRIPT language=JavaScript>
    <!--
    function MM_preloadImages() { //v3.0
      var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
        var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
        if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
    }
    
    function MM_swapImgRestore() { //v3.0
      var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
    }
    
    function MM_findObj(n, d) { //v4.01
      var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
        d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
      if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
      for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
      if(!x && d.getElementById) x=d.getElementById(n); return x;
    }
    
    function MM_swapImage() { //v3.0
      var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
       if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
    }
    //-->
    </SCRIPT>
    
    <BODY aLink="#f2f2f2" bgColor="#877867" link="#f2f2f2" onload="MM_preloadImages('http://site.voila.fr/kalonline/images/over.gif')" text="#f2f2f2" 
     vLink="#f2f2f2" style="margin:0px;">
    <TABLE border="0" cellPadding="0" cellSpacing="0" height="100%" width="100%">
      <TBODY>
      <TR align="left" vAlign="top">
        <TD><IMG height=50 src="http://site.voila.fr/kalonline/images/spacer.gif" width="50"></TD>
        <TD background="http://site.voila.fr/kalonline/images/background.gif" height=100% width="600">
    
          <TABLE align="center" border="0" cellPadding="0" cellSpacing="0" height="100%" 
          width="252">
            <TBODY>
            <TR align="left" valign="top">
              <TD width=211></TD>
              <TD align=middle height="100%" vAlign=top width=214>
    		  <IMG border="0" height=214 src="http://site.voila.fr/kalonline/images/main.gif"  width=252><BR><BR><BR>
    			<A href="http://pagesperso.laposte.net/dllimage/fanart/index.html" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('enter','','http://site.voila.fr/kalonline/images/over.gif',1)" 
                target="hidden"><IMG alt="ENTER" border="0" height="10" name="enter" 
                src="http://site.voila.fr/kalonline/images/enter.gif" width="252"></A><BR><BR><BR><BR><IMG border="0" 
                height=48 src="http://site.voila.fr/kalonline/images/sec.gif" 
                width="252"></TD>
              <TD width="211"></TD></TR></TBODY></TABLE></TD>
        <TD align="right"><IMG height="50" src="http://site.voila.fr/kalonline/images/spacer.gif" 
      width="50"></TD></TR></TBODY></TABLE>
    
    
    </body>
    </html>
    Tiens ça marche normalement :)
    Xou, 29 Avril 2005
    #15
  16. Offline
    K@ra SiouperSlapz0r
    vous vous cassez la tête pour rien, suffit de rajouter ça dans la balise BODY:
    Code:
    <BODY topmargin="0" bottommargin="0">
    K@ra, 29 Avril 2005
    #16
  17. Offline
    Xou I ♥ rien
    Moi c'était pour que les images se mettent bien sous firefox :)

    Merte j'ai oublié de matter sous IE du coup !!!

    EDIT : ouf ça marche :p
    Xou, 29 Avril 2005
    #17
  18. Offline
    PiaFlalCoOl NiuAge
    Un grand merci les gars !
    Je récupère le code et je le modifieraI.
    PiaFlalCoOl, 3 Mai 2005
    #18
  19. Offline
    PiaFlalCoOl NiuAge
    ça marche bien ! merci pour le code en CSS.
    Par contre avec l'autre, j'ai un prob, mais tant que ça marche...

    edit : mais je l'ai pas encore up.
    PiaFlalCoOl, 4 Mai 2005
    #19
  20. Offline
    Xou I ♥ rien
    Avec mon mien je suppose ?
    Erf ? Pourtant j'ai matté ça passait, le code de voila.fr pe :?
    Xou, 4 Mai 2005
    #20
Statut de la discussion:
Fermée.