BBOX + routeur + synology != SSH/rsync entrant?

Discussion dans 'Réseau, Wifi' créé par Sigismond, 13 Mai 2013.

  1. Offline
    Sigismond ex membre
    Hello!

    N'en pouvant plus du Wi-Fi pourri de la BBOX2, je me suis procuré un Belkin N600 DB. Je l'ai collé au derrière de ma bbox2, c'est génial, le Wi-Fi de type N est dispo, c'est plus stable et plus rapide, etc etc + possibilité de faire un "guest Wi-Fi" pour les invités (vu que je partage "tout" sur le réseau local).

    Bref.

    J'ai récemment acheté un Synology, qui fait des backups via rsync vers un serveur debian dans un datacenter. Jusque-là tout va bien, c'est facile et ça marche.

    J'aimerais néanmoins faire la même chose dans l'autre sens, à savoir récupérer des choses de mon serveur vers mon NAS, encore une fois par rsync. Première étape: me faire un compte type "Dyndns" (j'utilise le service gratuit offert par Synology). Cela fonctionne et mon IP est bien mise à jour automatiquement par mon NAS.

    Néanmoins, je rencontre un problème: lorsque, de l'extérieur (typiquement depuis mon serveur dans le datacenter) je "ssh -vvv" vers mon NAS, j'ai un timeout. J'ai pourtant bien configuré le NAS pour qu'il accepte le SSH (et pas que rsync)n et ce dernier a configuré mon routeur (via UPNP).

    Je me dis du coup que le problème doit venir de la bbox2?

    Une idée? Merci!

    edit:

    pour info, la bbox est en 192.168.1.1 et le routeur belkin en 192.168.2.1. Le NAS, tout comme tous les autres ordis/devices, est en 192.168.2.x

    edit²: selon http://www.canyouseeme.org/, mes ports 22 (SSH) et 873 (rsync) ne sont pas ouverts. Je ne trouve pas l'option dans la bbox, ça se configure en amont chez Belgacom?
    Sigismond, 13 Mai 2013
    #1
  2. Offline
    trigger Hiphop Addict
    trigger, 13 Mai 2013
    #2
  3. Offline
    Sigismond ex membre
    Yep merci

    J'ai oublié de dire que je l'avais déjà fait, du moins pour le port 22 (SSH), et que ça ne marche pas, toujours un timeout. :/

    Sans doute parce que mon NAS est sur 192.168.2.x alors que la bbox est sur la plage 192.168.1.x ... :/
    Sigismond, 13 Mai 2013
    #3
  4. Offline
    fraggahh ROFLCOPTER
    je suppose que si tu désactive le DHCP de ton belkin tu perds l'avantage du réseau guest ?

    L'idée c'était alors d'en faire un relais wifi et utilisant le dhcp du modem pour ne pas avoir un sous reseau.
    fraggahh, 13 Mai 2013
    #4
  5. Offline
    Sigismond ex membre

    Je perds en effet le guest :-(

    C'est lourd, tout ça parce que belgacom file une bbox mal pensée (ils offrent du 50 mbps... mais du wifi g, nice xd)
    Sigismond, 13 Mai 2013
    #5
  6. Offline
    tqz_ Elite
    vérifie que le port est bien ouvert (checkport . com) ou essaye en mettant ton nas en DMZ
    tqz_, 13 Mai 2013
    #6
  7. Offline
    Sigismond ex membre
    J'ai finalement passé le routeur belkin en access point. Par contre, génial, malgré que l'IP que j'ai notée soit bien la bonne, je ne retrouve plus l'IP du routeur... nice xd

    ( http://superuser.com/questions/149102/getting-ip-address-of-access-point xd )

    edit:

    après un reset du routeur, une configuration en AP, et le port forwarding qui va bien dans la bbox, j'ai donc bien accès maintenant à mon NAS via l'extérieur via SSH.
    Sigismond, 13 Mai 2013
    #7
  8. Offline
    fraggahh ROFLCOPTER
    ouais c'est le truc qu'il faut tjs checker avant de désactiver le DHCP. Et surtout etre certain que l'adresse du device est dans le même réseau que le DHCP et que l'ip n'est pas la même que le modem :D

    ca arrive encore souvent qu'ils mettent tous 192.168.1.254 ou 1.1 et après t'es bon pour le sortir du reseau, te mettre en IP statique et aller reconfig le tout :D
    fraggahh, 13 Mai 2013
    #8
  9. Offline
    Ch4zyx Elite
    Met ta BBOX2 en bridge, configure ton belkin pour qu'il etablise la connexion PPPOE (login@SKYNET et password). Du coup tu n'aura plus rien qui bloquera au niveau BBOX2. Si blocage il y a, il faudra alors ouvrir le port 22 dans la config du belkin.

    Tu en chiera bcp moins comme ça.

    Moi j'ai fais autrement, j'ai mis mon routeur en ip fixe 192.168.1.2, la passerelle 192.168.1.1 (bbox2) ainsi que les DNS de facon manuelle. La BBOX n'est pas en bridge, j'ai simplement mis mon routeur dans la DMZ de la BBOX, et sur la BBOX j'ai ouvert tous les ports UDP de 0 -> 65535 et TCP de 0 -> 65535, vers le 192.168.1.2

    Ensuite dans chaque network interface de la BBOX, tu decoche l'internet firewall, et enfin dans la network connection "lan bridge" tu met sur disable le serveur DHCP (ip distribution).

    Avec ça, ta bbox s'occupe seule de la connexion PPPOE avec login et pass (comme d'origine), mais tu n'aura plus aucuns blocage de port etc. Pas de DHCP fonctionnel, pas de firewall actif. Tout cela tu t'en occupera uniquement sur ton belkin.

    Il détectera probablement un double nat (c'est le cas de mon routeur apple), car l'ip sur ton port wan de ton routeur sera une ip privée. Mais comme les ports sont tous ouvert sur la bbox et aucun firewall, ca reagira comme si tu n'avais que la nat de ton belkin.

    Ca tourne au poil chez moi de cette façon avec mon synology, que ca soit en in ou en out :)
    Ch4zyx, 13 Mai 2013
    #9
  10. Offline
    wardog02 Fanatique
    wardog02, 13 Mai 2013
    #10
  11. Offline
    Sigismond ex membre
    Merci à vous, mais comme indiqué plus haut, c'est réglé :)
    Sigismond, 14 Mai 2013
    #11