Bug CSS

Discussion dans 'Web, design' créé par Xou, 6 Février 2008.

Statut de la discussion:
Fermée.
  1. Offline
    Xou I ♥ rien
    Hello, j'ai un petit soucis avec un site internet en développement

    http://usc.xyo.be/index.php

    En gros, le background ne va pas plus bas que 450px ...
    Est-ce que qqun aurait une idée pour étendre cela ?

    Si je ne mets pas l'attribu height par contre, le background va beaucoup moins bas.

    Merci d'avance.
    Xou, 6 Février 2008
    #1
  2. Offline
    Maleki Pain in the ass !
    Il faut éviter d'indiquer une hauteur fixe à ton background si la hauteur du contenu est variable.
    Pour ton problème, essaie "overflow: hidden;" dans le code css de ta div "main".
    Maleki, 6 Février 2008
    #2
  3. Offline
    Xou I ♥ rien
    Merci ça fonctionne presque nickel.
    Le soucis est que le menu est en partie caché, comme il est remonté.

    L'attribut est z-index pour mettre un calque en avant par rapport à un autre ?
    J'ai tenté cet attribut sans succès.
    Xou, 6 Février 2008
    #3
  4. Offline
    Maleki Pain in the ass !
    Je suppose que tu utilises une position relative ou absolue pour ton menu ?
    Si oui, je le placerais simplement comme float à gauche.
    Il ne sera pas à la bonne hauteur mais au moins au même niveau que ton contenu.
    Quand au z-index, aucune idée, je n'ai jamais utilisé cette attribut.
    Maleki, 7 Février 2008
    #4
  5. Offline
    Xou I ♥ rien
    En fait, c'est déjà le cas, juste que je le mets en position -> top:-70px pour le faire remonter. Et c'est ça le soucis, c'est qu'il se place en dessous du calque.
    Xou, 7 Février 2008
    #5
  6. Offline
    Maleki Pain in the ass !
    Je viens de regarder un peu plus en détail ton code. As-tu déjà essayer de déplacer la div "top" dans la div "main" (histoire qu'elle est le même parent que le menu) ?
    Maleki, 7 Février 2008
    #6
  7. Offline
    Xou I ♥ rien
    Ca fonctionne nickel effectivement si on met le "top" dans le "main", mais le soucis en fait, c'est que si je fais ça, les PNG avec transparence vont foirer.

    Donc reste comme solution de ne pas faire ce top:-100 ou mettre le menu dans le top et non dans le main, mais en essayant j'ai un bug encore plus voodoo. Youhooouuuu.

    Je réessaierai un truc tout à l'heure, merci pour ton aide et les idées que tu donnes en tout les cas.
    Xou, 7 Février 2008
    #7
Statut de la discussion:
Fermée.