[CSS]problème background

Discussion dans 'Web, design' créé par julien_, 21 Août 2007.

Statut de la discussion:
Fermée.
  1. Offline
    julien_ harkor.be
    voici mon code
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
    <head>
    	<title>Lorette Martens</title>
    	
    	<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    </head>
    <body>
    
    	<div id="header" style="background-image:url('images/header.jpg');">
    		
    	</div>
    	
    	<div id="contenu">
    	
    	</div>
    	
    	<div id="footer">
    		
    	</div>
    	
    </body>
    </html>
    Seulement l'image d'arriere plan n'arrive pas...
    Mon image se trouve à l'emplacement indiqué... Si je fais passer le code via une page css ça revient au même...

    Je vois vraiment pas le problème :-s


    PS: ça marche sur mes autres sites mais pas celui-ci :-s
    julien_, 21 Août 2007
    #1
  2. Offline
    FoX SpeEd Touriste
    c'est normal tu met un background sur une div qui ne contient rien donc la div ne "s'affiche" pas. Pour que tu comprenne ecrit un quelque chose dans la div et tu verra le background,enfin une partie ...
    FoX SpeEd, 21 Août 2007
    #2
  3. Offline
    julien_ harkor.be
    Lorsque je met une taille ça ne change rien...
    J'ai mis une bordure lorsque je met une taille pour vérifier et ça n'affiche rien...
    julien_, 21 Août 2007
    #3
  4. Offline
    julien_ harkor.be
    Bon je ne sais par quel miracle ça fonctionne comme ça sauf que mon but premier était de taper ça dans ma css =/
    Et je copie-colle le code et ça va pas... Si je lui défini une taille et tout avec une bordure la bordure s'affiche...

    Code:
    body {
    	background: #000;
    	width: 900px;
    	margin: auto;
    }
    
    #header {
    	background-image: url('images/header.jpg');
    	width: 900px;
    	height: 145px;
    	border: 1px solid red;
    }
    Ma bordure touge s'affiche à la taille indiquée mais rien en background...
    julien_, 21 Août 2007
    #4
  5. Offline
    CiDoUm ListMinut.be
    Tu peux mettre ce code: "background-image:url('images/header.jpg'" directement dans ton fichier CSS :)
    CiDoUm, 21 Août 2007
    #5
  6. Offline
    eSb` That's Poker!
    T'as essayé, comme le dit FoX SpeEd, de mettre du texte dans ton div ?

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
    <head>
    	<title>Lorette Martens</title>
    	
    	<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    </head>
    <body>
    
    	<div id="header" style="background-image:url('images/header.jpg');">blabla
    		
    	</div>
    	
    	<div id="contenu">
    	
    	</div>
    	
    	<div id="footer">
    		
    	</div>
    	
    </body>
    </html>
    eSb`, 21 Août 2007
    #6
  7. Offline
    julien_ harkor.be
    J'ai trouvé la solution... Etant donné que mes feuilles de styles se trouvaient dans un dossier css
    et mes images dans le dossier images le lien n'est plus images/hffhfh.jpg mais ../images/hfjffh.jpg


    Voilà :D
    Merci quand même
    julien_, 21 Août 2007
    #7
Statut de la discussion:
Fermée.