DEMANDE: COMMENT FAIRE ?

Discussion dans 'Web, design' créé par 123_GO, 11 Février 2006.

Statut de la discussion:
Fermée.
  1. Offline
    MbK_ Etudjant

    en effet, c'est deja sur qu'il y a une erreur dans cette page car elle n'enregistre pas les donnée dans ta db...

    Il y a un message d'erreur qd tu tentes d'en enregistrer une?
    MbK_, 13 Février 2006
    #21
  2. Offline
    123_GO ex membre
    Non aucun message d'erreur
    il me dirige comme prevu vers la page "liste_teams.php"
    Mais il n'y a pas la team que je vient d'inscrire...
    123_GO, 13 Février 2006
    #22
  3. Offline
    123_GO ex membre
    Je vous donne ceci si sa peu aidée:
    C'est la table que j'ai crée


    Je vient de testé de mettre une données part "phpmyadmin"
    Et part la sa marche!!!!!!

    -> Ceci prouve qu'il a une erreur dans "liste_teams.php" vue que la données que j'ai crée part phpmyadmin, je clique sur supprimer et RIEN ne se PASSE! ET quand je clique sur modifier il me marque les données que j'ai inscrite mais il ne les modifie pas ! (= a noter que on a été envoyer dans "inscrire_teams")
    -> Aussi inscrire une nouvelle team ne marche pas non plus donc la aussi il dois i avoir une erreur!

    --> Je pense pas que ceci est du a la base de données mais une faute dans les pages meme...
    123_GO, 13 Février 2006
    #23
  4. Offline
    Calvin80 Elite
    en haut de tte tes pages, fait un "print_r($_GET)" et "print_r($_POST)".

    à mon avis tu as une variable qui passe pas et donc ta query se fait pas...
    Calvin80, 13 Février 2006
    #24
  5. Offline
    123_GO ex membre
    Quand je marque
    Tout en haut des pages il me marque:


    EDIT:
    10 min apres:
    J'ai modifier team_inscrite.php
    Que tout le monde sais voir et il marche il affiche la donnée que j'avai ajouter avec "phpmyadmin".
    Mais l'ajout des equipe part le site ne marche toujour pas...
    Vous pouvez verifier: http://www.eternity-online.ispi.be/pulse/team-inscrite.php
    J'ai changer le code en celui si:
    [/url]
    123_GO, 14 Février 2006
    #25
  6. Offline
    Calvin80 Elite
    apres chaque print_r, n'oublie pas tes ";" :idea:
    Calvin80, 15 Février 2006
    #26
  7. Offline
    123_GO ex membre
    Ah voila il marque l'erreur suivante au dessus de "inscrire_teams.php" et aussi au dessus de "liste_teams.php"

    Au dessus
    Quand je marque les données, dans "inscrire_teams.php" et je marque sur envoyer il me renvoi sur "liste_teams.php" ce qui est normal mais au deçu il marque:
    Dans "liste_teams.php", si je clique sur supprimer il me marque:
    Et si je clique sur Modifier il m'envoi sur "inscrire_teams.php" avec les données a modifier mais en haut il marque:

    Voila...
    123_GO, 15 Février 2006
    #27
  8. Offline
    Calvin80 Elite
    et ben voila: dans liste_team...
    tu test si tu as un $_POST['team'], or y'en a pas puis que ton $_POST contient :

    Array ( [titre] => fsq [player1] => fsq [player2] => fqs [player3] => fqs [player4] => fsq [player5] => fqs [server] => fsq [id_teams] => 0 )


    donc il ne fait pas d'enregistrement...
    Calvin80, 16 Février 2006
    #28
  9. Offline
    123_GO ex membre
    Exactement je dois changer quoi ?
    Je n'ai pas trop compris ou je ne sais pas trop quoi changer...
    123_GO, 16 Février 2006
    #29
  10. Offline
    123_GO ex membre
    ...
    123_GO, 19 Février 2006
    #30
Statut de la discussion:
Fermée.