[Excel] Condition (=Si(...))

Discussion dans 'Windows' créé par Onefive, 14 Juin 2006.

Statut de la discussion:
Fermée.
  1. Offline
    Onefive Freddy Tougaux
    Bonsoir tout le monde,

    Voila j'aurai aimer savoir si quelqu'un pouvais éclairer ma lanterne.

    J'ai comme énoncer

    ... Dans la colonne B, indiquer le nombre de fautes commise entre 0 et 10. Dans la colonne C utiliser la fonction Si qui indiquera un message adéquat en fonction du nombre encodée en colonne B.

    Données à suivre:

    -Si les fautes <3: on affiche "Rien à signaler"
    -Si les fautes > ou = 3 mais <5: on affiche "2 heures de retenue"
    -Si les fautes > ou = 5 mais <7: on affiche "Journée de renvoi"
    -Si les fautes > ou = 7: on affiche "Conseil de discipline"

    J'ai donc bien suivi les données etc et j'ai obtenu ceci comme formule:

    =SI(B1<=3;"Rien à signaler";SI(B1>=3<5;"2Heures de retenue";SI(B1>=5<7;"Journée de renvoi";SI(B1>=7;"Conseil de discipline";""))))

    Mon problème réside lorsqu'il y a deux chiffres (> ou = 3 mais <5 et > ou = 5 mais <7)

    Quand j'inscrit en colonne B les chiffres compris entre 4 et 7 ca n'affiche rien :pfiou: :-(

    Quelqu'un peut il m'aider?

    merci d'avance
    Onefive, 14 Juin 2006
    #1
  2. Offline
    CptDobey ex membre
    Heu...
    Il y a quelques problèmes de logique.

    Par exemples:
    - Pourquoi mettre <=3 puis mettre >= 3 ?
    - Pourquoi mettre le dernier test >= 7 ?

    Je ne suis pas certain que "B1>3<=5" soit un test correct...
    Là aussi il y a un problème de logique. Si ce test est évalué, c'est que fatalement b1 est supérieur ou égal à 3. Pourquoi l'écrire ?

    En résumé:
    =Si (b1<3;"Rien...";si(b1<5;"2 heures...";si (b1<7;"Journée";"Renvoi")))
    CptDobey, 14 Juin 2006
    #2
  3. Offline
    Roudoudou Lecteur discret
    C'est surement parce que tes tests logiques ne valent pas grand choses. Essaye les simplements dans une cellules pour tester.

    Je te propose ceci.

    =SI(B4<3;"Rien à signaler";SI(B4<5;"2 heures de retenue";SI(B4<7;"Journée de renvoi";SI(B4<=10;"Conseil de discipline"; "Mauvaise entrée"))))

    Essaye juste "=B1>=3<5" dans une cellule pour voir le resultat qu'il donne tu comprendras que pour Excel "B1>=3<5" c'est incrompéhensible ;)
    Roudoudou, 14 Juin 2006
    #3
  4. Offline
    CptDobey ex membre
    On ne peut pas faire plus que 10 fautes ?
    Tu es optimiste et tu n'as jamais vu mes contrôles de français :-D
    CptDobey, 14 Juin 2006
    #4
  5. Offline
    Roudoudou Lecteur discret

    Si tu lisais tes enoncés tu aurais déjà une faute en moins :p ;)
    Roudoudou, 14 Juin 2006
    #5
  6. Offline
    CptDobey ex membre
    Tu disais ?
    On ne parle pas de traitement d'erreur :p
    Ou alors il faut aussi traiter les entrées négatives, au moins.

    Blague à part, tu as raison :dead:
    CptDobey, 14 Juin 2006
    #6
  7. Offline
    Roudoudou Lecteur discret
    Tu as raison pour les entrées négatives ! Tu m'as KC :-9

    Mais ca te fait donc deux oublis :-D

    Je rigole hein, je rentre pas dans les cassaches de bas étage... tant qu'il a compris son erreur ;)
    Roudoudou, 14 Juin 2006
    #7
  8. Offline
    Onefive Freddy Tougaux
    Merci de vos réponses, mais ca ne semble pas être ça.

    Je vais continuer de chercher :)
    Onefive, 14 Juin 2006
    #8
  9. Offline
    Roudoudou Lecteur discret
    Voila le résultat que tu obtiens avec nos formules.

    Ca ne te semble pas être ce que tu demandes ? Quelles sont les différences que tu attends ?

    [IMG]
    Roudoudou, 14 Juin 2006
    #9
  10. Offline
    Onefive Freddy Tougaux
    ... quelle formule est ce? (dans celle que vous m'avez proposer) j'ai du me tromper ou quoi en recopiant.
    Onefive, 14 Juin 2006
    #10
  11. Offline
    Roudoudou Lecteur discret
    =SI(B1<3;"Rien à signaler";SI(B1<5;"2 heures de retenue";SI(B1<7;"Journée de renvoi";SI(B1<=10;"Conseil de discipline"; "Mauvaise entrée"))))

    Pour les explications, lis les posts de CptDobey et les miens. Tu devrais comprendre ton erreur.
    Roudoudou, 14 Juin 2006
    #11
  12. Offline
    Onefive Freddy Tougaux
    Merci beaucoup :p j'ai compris :-D :-D :-D
    Onefive, 15 Juin 2006
    #12
Statut de la discussion:
Fermée.