[flash] modification de clip

Discussion dans 'Web, design' créé par MbK_, 15 Novembre 2004.

Statut de la discussion:
Fermée.
  1. Offline
    MbK_ Etudjant
    Bonjour à tous!

    suite au commencement d'une petite intro, j'ai un probleme de realisation que je ne comprends absolument pas.

    explication en francais : (les sources suivront)

    j'ai un petit logo dans un clip. Et j'agrandis ce clip en modifiant son opacité sur une dixaine de frames avec une interpolation de mouvement. Jusque là, ca devrait aller mais ca ne marche pas lorque c'est en SWF. Alors que qd je tappe sur "enter", ca se passe bien.

    Apres avoir trifouillé le code de mon preload, je me suis rendu compte que en mettant
    Code:
    if (loaded_bytes == total_bytes) {
    	nextScene();
    ca ne marche pas alors que en mettant
    Code:
    if (loaded_bytes == total_bytes) {
    		nextScene(0);
    ca marchait mais il y a une erreur qui apparait.


    Code:
    **Erreur** Séquence = Preload, calque = code, image = 3 :Ligne 4 : Nombre de paramètres incorrect. nextScene nécessite exactement 0.
         	nextScene(0);
    
    Total des erreurs ActionScript : 1 	 Erreurs signalées : 1
    nextScene nécessite exactement 0.

    cela veut dire que l'action nextScene() a automatiquement la valeur 0?

    mais dans ce cas, pouquoi est-ce que en ne mettant aucune valeur, le clip que je fait modifier ne va pas?

    si vous voulez plus d'explications, ... je suis dispo :p
    MbK_, 15 Novembre 2004
    #1
Statut de la discussion:
Fermée.