[HELP] Serveur WEB accessible du net

Discussion dans 'Web, design' créé par WaKaaN, 29 Février 2008.

Statut de la discussion:
Fermée.
  1. Offline
    WaKaaN JcQL
    Bon... Apres avoir fait de multiples recherches, j'ai trouvé tout ce qui faut pour créer mon serveur web, seulement, il n'est accessible qu'en local!!

    Je suis sur Ubuntu et j'ai installé : Apache, mysql, php, phpmyadmin...


    Maintenant, ici n'est pas le débat à propos du pour ou contre la création d'un hebergeur chez soi, je voudrais juste que ca marche...

    Merci d'avance!

    (Un explication step by step serait bienvenue...)

    INFO : Lorsque je tape mon adresse ip (genre : whatsmyip.com), je tombe sur la config de mon routeur...

    IP dynamique + Routeur DLink DSL-G6004T


    Thx for your help :)
    WaKaaN, 29 Février 2008
    #1
  2. Offline
    Jereck Procrastinateur
    Equipe GamerZ.be
    dans ton routeur, tu dois rediriger le port 80 vers ton serveur ;)

    (file-moi ton adresse IP en PM, que je teste si je tombe aussi sur ta config de routeur, ce qui est pas super normal)
    Jereck, 29 Février 2008
    #2
  3. Offline
    admix G!v3 m3 a 60v3rnm3n7
    ^c'est toi qui en tapant tona dresse ip tombe sur ta page de config ou bien un pot a qui tu as donné l adresse et qui teste de l'extérieur.
    admix, 29 Février 2008
    #3
  4. Offline
    WaKaaN JcQL
    Pour l'instant, c'est moi, maintenant je viens de donner mon adresse ip a Jereck qui va verifier si lui aussi sait y acceder...


    Maintenant, je voudrais savoir comment rediriger un port 80 sur mon routeur...

    C'est un DLink, et j'ai une ip dynamique

    Thx: )
    WaKaaN, 29 Février 2008
    #4
  5. Offline
    Jereck Procrastinateur
    Equipe GamerZ.be
    nan, sa config routeur n'est pas accessible depuis l'extérieur ;)

    je suppose que le routeur détecte que l'adresse (publique) auquelle il veut accéder est la sienne et "redirige" automatiquement son port 80 "public" vers sa page de config.


    maintenant, les DLink, je connais pas les pages de config...
    Jereck, 29 Février 2008
    #5
  6. Offline
    admix G!v3 m3 a 60v3rnm3n7
    tu vas dans routing table un truc comme ça
    admix, 29 Février 2008
    #6
  7. Offline
    WaKaaN JcQL
    Dans les options de mon routeur (DSL-G604T) il y a un menu : Port Forwarding.. A cet endroit, j'ai une option Serveur Web où les seuls informations sont les ports 440 et 80... Je l'ai donc ajouté pour mon ip local (192.168.1.2)...

    Ca ne change rien... :/

    Edit: Info peut-être utile, il n'est configurer que pour le tcp et non pas pour l'udp...
    WaKaaN, 29 Février 2008
    #7
  8. Offline
    admix G!v3 m3 a 60v3rnm3n7
    il ne faut pas cocher une case activé ou un truc comme çA?
    admix, 29 Février 2008
    #8
  9. Offline
    WaKaaN JcQL
    [IMG]

    Voila ce qu'il y a... Je l'ai ajouter dans les "applied rules"
    WaKaaN, 29 Février 2008
    #9
  10. Offline
    WaKaaN JcQL
    Bon rien n'y fait...

    J'ai tout essayé, me suis meme retrouvé sans connection alors que mon autre pc lui avait bien la connexion....

    Maintenant tout est rentré dans l'ordre, mais mon serveur ne marche tjs pas... :/

    Une idée comme ca? (Normal que ca soit si compliqué? )


    Voici ce que j'ai fait :

    J'ai trouvé ceci comme option :
    J'ai activé Remote Web
    IP Address : 192.168.1.2
    IP Net Mask:255.255.255.0

    Résultat : Rien ne change mis à part que mon ip qui disparait de la liste déroulante lorsque je veux appliquer des ports forwarding pour ma machine... :/


    AH WI, J'ai une ip dynamique pour finir, et non pas statique... (C'est nouveau)

    Ensuite, je remets tout par défaut. Ce coup-ci je vais dans l'option "Access control", j'active comme dit précédemment le Webserver pour 192.168.1.2 et là, je n'ai plus de connection sur mon pc, mais sur les autres de mon réseau, tout roule nickel... :/
    WaKaaN, 29 Février 2008
    #10
  11. Offline
    WaKaaN JcQL
    Bon j'ai édité mon post juste au dessus... Help ! Y a rien qui marche :cry:
    WaKaaN, 29 Février 2008
    #11
Statut de la discussion:
Fermée.