Linux + cedega + trackmania nation

Discussion dans 'Windows' créé par Lynch_raider, 22 Mars 2006.

Statut de la discussion:
Fermée.
  1. Offline
    Lynch_raider Elite
    Bonjours,

    J'aimerais savoir si quelqu'un a réussi à faire tourner Trackmania nation sous Linux à l'aide du soft "Cedega".

    Le jeu est bien présent dans la liste des jeux compatibles :
    http://transgaming.org/gamesdb/

    Donc en fait chez moi il installe bien le jeu, mais lorsque j'essaye de le lancer à l'aide de Cedega, il me dit qu'il ne trouve pas la carte graphique, hors les drivers de la carte son bien installé et quand je regarde dans les informations hardware il les trouves.


    Si quelqu'un à eu le problème et à réussi à faire tourner, je suis prenneur des infos, et merci d'avance...
    Lynch_raider, 22 Mars 2006
    #1
  2. Offline
    ImMorT4L Touriste
    Si tu as lu qu'il est compatible, c'est qu'il a été testé... Il y a moyen de le faire fonctionner.

    Quand tu dis que ta cartes est installée, as tu déjà installé un autre jeux ou prog 3D ??? Ati ou nVidia ???
    ImMorT4L, 22 Mars 2006
    #2
  3. Offline
    [HCS]VaLiuM Elite
    tu as optimisé linux pour ta carte graphique
    [HCS]VaLiuM, 22 Mars 2006
    #3
  4. Offline
    Nmy Touriste
    de base ta carte graophique est installe oui pas le 3d

    pour un chip nvidia sur nvidia tu as le driver fourni et un tuto d explication qui est assez simple.... ensuite tu verras une anim 3d la ca marchera

    pour ati je suppose que ca existe perso g jamais eu d ati avec linux
    Nmy, 22 Mars 2006
    #4
  5. Offline
    Lynch_raider Elite
    Donc en fait j'ai une Ati 9800 pro, et je suis bien allé cherché les drivers sur le site d'ati pour la distribution de linux que j'ai (mandiva 2006) donc les drivers sont bel et bien installés .

    Sinon je me doute bien que il a été testé si il est dans la liste, mais c'est la liste du développeur , donc oui il doit aller mais j'ai un message d'erreur et j'aurrais même pas essayé si je l'avais pas vu dans la liste.

    Pour se qui est d'essayer un autre jeu , j'ai pas encore essayé mais je testerais demain
    Lynch_raider, 23 Mars 2006
    #5
  6. Offline
    Arnpsyke Charlatan
    j ai une 6800 GT de nvidia et je confirme qu il fonctionne sans problèmes sous mon linux ubuntu. J ai acheté la version de cedega. Dans le programme (point2play) il y a une fonction pour tester la carte 3D, son et peripheriques. Si le test est réussi, tu ne devrais pas avoir trop de problèmes. Pour les autres jeux que j ai mis avec succès: CS source, GTA III, World of Warcraft, need for speed underground. Je n'ai testé que cela aussi :) Bref, c est du 100% pour l'instant :). J adore ce programme
    Arnpsyke, 23 Mars 2006
    #6
  7. Offline
    ImMorT4L Touriste
    Fait nous un copier coller de la commande fglrxinfo et combien de fps te donne la commande glxgears ???

    > Avec ma 9700Mobility, je tape 2200fps +/-, tu devrais être vers les 3000 en toute logique :)
    Même ma Rédeon Mobility 8Mb fonctionne... Mais vers les 150fps :D

    Les ATI sont souvent capricieuses et plus compliquées à installer que les nVidia, ATI n'a jamais été très fort pour sortir de bons drivers et c'est encore plus visible sous Linux...
    ImMorT4L, 23 Mars 2006
    #7
  8. Offline
    Lynch_raider Elite
    fglrxinfo:

    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON 9800 SE Generic
    OpenGL version string: 2.0.5695 (8.23.7)

    glxgears:

    51 frames in 5.1 seconds = 10.075 FPS
    49 frames in 5.0 seconds = 9.800 FPS
    45 frames in 5.0 seconds = 8.982 FPS
    49 frames in 5.0 seconds = 9.722 FPS
    49 frames in 5.0 seconds = 9.782 FPS
    49 frames in 5.0 seconds = 9.710 FPS
    49 frames in 5.0 seconds = 9.784 FPS
    49 frames in 5.0 seconds = 9.791 FPS
    50 frames in 5.1 seconds = 9.837 FPS
    49 frames in 5.0 seconds = 9.800 FPS
    49 frames in 5.0 seconds = 9.776 FPS
    49 frames in 5.0 seconds = 9.798 FPS
    50 frames in 5.1 seconds = 9.813 FPS
    50 frames in 5.1 seconds = 9.829 FPS
    50 frames in 5.1 seconds = 9.802 FPS
    50 frames in 5.1 seconds = 9.823 FPS
    .............
    Lynch_raider, 23 Mars 2006
    #8
  9. Offline
    Arnpsyke Charlatan
    ben voilà le problème. tes drivers sont foireux. Réinstalle bien les drivers ati et la librairie opengl
    Arnpsyke, 23 Mars 2006
    #9
  10. Offline
    Lynch_raider Elite
    Ben effectivement

    18026 frames in 5.0 seconds = 3605.130 FPS
    20346 frames in 5.0 seconds = 4069.133 FPS
    20279 frames in 5.0 seconds = 4055.750 FPS
    20278 frames in 5.0 seconds = 4055.555 FPS
    20347 frames in 5.0 seconds = 4069.222 FPS
    20357 frames in 5.0 seconds = 4071.235 FPS
    20346 frames in 5.0 seconds = 4069.168 FPS
    20342 frames in 5.0 seconds = 4068.391 FPS
    19675 frames in 5.0 seconds = 3934.811 FPS
    20353 frames in 5.0 seconds = 4070.405 FPS
    20254 frames in 5.0 seconds = 4050.778 FPS
    ........

    Donc de se coté la c'est réglé, merci beaucoup pour l'info. En fait à la base j'ai mis les drivers du site ATI et l'instalation avait l'air de c'être bien passée, mais la je viens de mettre les drivers qui sont conpris dans les paquetages de la distrib, et ceux ci ont l'air d'aller mieux.

    Cependant, il veut toujours pas lancer le jeu donc je vais aller essayer un autre.
    Lynch_raider, 23 Mars 2006
    #10
  11. Offline
    Arnpsyke Charlatan
    bizarre bizarre, cela dit, j ai eu beaucoup de problèmes aussi avec la mandrake (depuis ubuntu ça va beaucoup mieux). Fais comme je t'ai dit, lance le diagnostic de point2play pour voir si erreur il y a. Sinon quand tu lance le jeu il y a normalement un fichier de débogage créé dans le répertoire du jeu ou de transgaming (à verifier je suis sur mon mac là mon pc sous linux est à la maison). Piste que tu peux envisager c est le support de l'alsa par ta carte son. Peut etre essayer de le désactiver via le panneau de config de point2play
    Arnpsyke, 23 Mars 2006
    #11
  12. Offline
    Lynch_raider Elite
    décidément en fait , meme pas besoin d'essayer un autre jeu

    32 frames in 5.1 seconds = 6.228 FPS
    45 frames in 5.0 seconds = 8.987 FPS
    46 frames in 5.0 seconds = 9.125 FPS
    48 frames in 5.1 seconds = 9.420 FPS
    50 frames in 5.0 seconds = 9.966 FPS
    50 frames in 5.0 seconds = 9.972 FPS
    50 frames in 5.0 seconds = 9.972 FPS
    32 frames in 5.0 seconds = 6.356 FPS
    38 frames in 5.0 seconds = 7.559 FPS

    Je crois que je vais garder mon multi-boot jusqu'a ma prochaine envie de régler se problème.

    Sinon, pour se qui est du "system test" , je fais run all et il me met "passed" partout.
    Lynch_raider, 23 Mars 2006
    #12
  13. Offline
    Arnpsyke Charlatan
    ca va peut etre t'aider :

    ous étes nombreux à avoir des problème avec mandriva 2006 et l'accélération graphique pour cartes ATI.
    Mandriva 2006 est livré aves Xorg6.9 (tapez X -version pour voir). Cette version n'est pas encore officielle, et les drivers ATI ne sont pas livrés avec mandriva 2006 (sauf pour les membres du club).
    Mais la solution est simple; je la décompose en 2 étapes:

    1- retrouver le serveur graphique
    Je vais décrire en premier lieu une méthode en ligne de commande qui j'ai personellement utilisé.

    si vous étes en mode console, rester y, sinon démarrez en mode failsafe
    passer en root: su root
    installer mc: urpmi mc (mc est un petit gestionnaire/éditeur de fichiers en mode semi graphique)
    ouvrir mc: mc
    chercher le fichier/etc/X11/xorg.conf
    modifier la ligne : section device ligne driver par "vesa".
    Enregistrer et quitter.
    Redémarrez en mode graphique. Tout devrais marcher.
    Il existe une variante spécifique mandrake mais que je n'ai pas testé:
    . Passez en mode root (voir ci dessus).
    . Lancez xdrak11 (interface qui permet de reconfigurer les pilotes et la
    definition graphique). Tapez xdrak11.
    . Passez en mode vesa (utilisez le tab et les touches directionnelles du clavier pour se déplacer).
    . En gros faut choisir la carte, puis le pilote (vesa) et la definition de l'ecran.
    . Valider losque il demande lancement automatique au démarrage.
    . Rebooter.
    Au prochain demarrage l'interface graphique se lance sans probleme.

    ATTENTION: j'ai un des problémes de plantage avec les drivers ATI et le noyau 2.6.12 smp, donc utilisez plutot un noyau 2.6.12-17 par ex (la version upto1GB fonctionne aussi)

    2- installer des drivers 3D ATI

    2.1 méthode depuis le site ATI
    creer un repertoire rpm
    allez sur le site d'ATI charger l'installeur (ati.driver-installer-8.20.8-i386.run) et mettez le dans le répertoire rpm.
    rendez ce fichier exécutable
    ouvrez une console et passez root
    installez les sources du noyau si ce n'est pas fait (urpmi kernel-source).
    cd rpm
    ./ati.driver-installer-8.20.8-i386.run
    choissisez la génération de modules pour mandriva 2006
    Cela va creer 3 fichiers .rpm
    urpmi fichier1 fichier2 fichier3
    XFdrake
    choisissez votre carte graphique (ATI avec accéllération matérielle)
    en console, en root: aticonfig -- initial
    La commande aticonfig permet d'autres réglages, à vous de les découvrir (aticonfig liste les commandes).
    reboot, puis
    glxgears pour voir si tout est OK (ou fgl_glxgears).

    2.2 install depuis les rpm mandriva
    Ils sont enfin sortis !
    mettez votre systéme à jour depuis les dépots internet (voit tuto correspondant)
    Installez ati-xorg (version 8.22.5-0.1.20060plf à ce jour), dkms-ati, et leurs dépendances.
    XFdrake
    choisissez votre carte graphique (ATI avec accéllération matérielle)
    en console, en root: aticonfig -- initial
    La commande aticonfig permet d'autres réglages, à vous de les découvrir (aticonfig liste les commandes).
    reboot, puis
    glxgears pour voir si tout est OK (ou fgl_glxgears).

    Faites nous part de vos installs!
    Arnpsyke, 23 Mars 2006
    #13
  14. Offline
    Lynch_raider Elite
    cool ben au moin je suis fixé, merci bcp. J'essaierais ca se soir.

    Par contre, tu la tiré de l'article ?
    Lynch_raider, 23 Mars 2006
    #14
  15. Offline
    Arnpsyke Charlatan
  16. Offline
    Arnpsyke Charlatan
  17. Offline
    Lynch_raider Elite
    je viens de tester la méthode mais il a pas trop apprécié le premier point, au redémarrage il ma fait un truc genre comme quand on met une frequence trop élevée pour l'écran ........

    Et merci beaucoup pour le site, je vais aller voir avec celui qui a fait l'article ...
    Et merci quand même pour vos coups de main.

    Je pense que je vais tester unbutu se w-e, et comme ati me déçoit de plus en plus je vais finir par me pencher sur NVIDIA pour ma prochaine config pour apres les vacances d'été.
    En fait le jeu, n'est pas vraiment indispensable , mais comme je cherche un système alternatif a windows qui soit vraiment opérationnel .... Donc prochains test sur unbutu et je tiendrais au courrant si sa fonctionne ou pas.

    ++
    Lynch_raider, 23 Mars 2006
    #17
  18. Offline
    ImMorT4L Touriste
    Mandriva c est pas ma tasse de thé, mais les problèmes sont bien là... Je ne sais pas si les .rpm sont une bonne solution, j'irais plustot voir du côté des sources et même des CVS si possible.

    Voilà la version que j'utilise, ce sont les 8.21.7, j'avais des problèmes avec une version plus ancienne :)
    ImMorT4L, 23 Mars 2006
    #18
  19. Offline
    Arnpsyke Charlatan
    +1 j ai viré mandriva. Trop propriétaire à mon gout. Les meilleures distributions sont celles basées sur la debian. xandros, ubuntu. Jamais eu de problemes avec
    Arnpsyke, 23 Mars 2006
    #19
  20. Offline
    cyberdelique ex membre
    je ne suis vraiment pas sur que trackmania fonction avec cedega, a cause de starforce (toujours lui, cte saloperie...)
    cyberdelique, 27 Septembre 2006
    #20
Statut de la discussion:
Fermée.