Linux => Comment faire fonctionner ma carte graphique ?

Discussion dans 'Windows' créé par Xaab, 25 Février 2004.

Statut de la discussion:
Fermée.
  1. Offline
    guslinux Gamerz'ien
    guslinux, 26 Février 2004
    #21
  2. Offline
    Xaab Touriste
    Le rpm s'installe oui. Et le driver est bien présent dans la liste.

    Mais ma carte n'est pas reconnue. Je vais réinstaller Linux. Mais je pense que le problème vient surtout que mon ancienne carte graphique est toujours présente. Vu que c'est un chipset intégré à la carte mére. Peut-être faut-il que je la désactive avec un cavalier ou je ne sais pas quoi. Enfin c'est pas gagné quoi :?
    Xaab, 26 Février 2004
    #22
  3. Offline
    [HCS]VaLiuM Elite
    par hazard, tu as été voir sur le site d'hercules, pour voir il n'a avait pas un driver linux :wink:
    [HCS]VaLiuM, 26 Février 2004
    #23
  4. Offline
    dagibbon Elite
    Dans la famille "monstro-quote" je demande le fils!
    dagibbon, 26 Février 2004
    #24
  5. Offline
    guslinux Gamerz'ien
    g du mal à comprendre, tu as une image sur ta carte ou pas du tout ? car si t'as pas d'image oui il faut désactiver la carte et le cas echeant la configuré dans linux, avec deux ecrans à ce moment là...
    guslinux, 26 Février 2004
    #25
  6. Offline
    TheNastyBoy B0rn t0 b3 r00t
    Tu devrais vite désactiver ta carte intégrée dans ton BIOS, car il arrive que cela cause des problèmes de conflit matériel (sous win principalement je pense).
    Ensuite, histoire d'être propre sur sa machine, tu sauvegardes ce qui t'intéresse sous Linux et bien entendu le pilote ;) N'oublie pas d'aller lire le README ou les instructions d'installation sur le site. Si tu as du mal en Anglais, n'oublie pas que Google est ton meilleur ami, ce n'est pas un fin traducteur mais cela reste compréhensible (et si t'as un ami bon en angalis ça ira).
    Tu installe ton Mandrake Linux. Je pense qu'il te proposera un pilote ATI générique, vu que la 9600 est sortie bien après ta Mandrake 9.1 .
    Ensuite c'est là que ça se corse, mais ça ne devrait pas être trop dur. Il te faut quelques notions sur le monde console car pour éviter des conflits logiciels il est préférable de désactiver l'interface graphique pendant que tu installes le pilote. Si tu n'as aucune notion sur le terminal et ses commandes, envoie moi un MP on prendra contact pour que je te montre...
    Tu as de la chance : Mandrake Linux est une distro où les softs sont faciles à installer grâce au système de paquetages RPM. Pour installer ton driver, tapes la commande "urpmi nomdupackage.rpm".
    Pour "éteindre" l'interface graphique, il suffit de taper en root dans un terminal "telinit 3". Redémarre l'interface graphique après l'install.

    Je crois que j'ai tout dit. Si j'ai oublié quoi que ce soit ou que tu veux des renseignements; MP-moi.
    TheNastyBoy, 26 Février 2004
    #26
  7. Offline
    baze Touriste
    en fait je pense que tu dois configurer XFREE pour qu'il utilsie tes drivers fraichment installé ... genre sous windows cé pas parceke tu décompresses ton zip avec ton driver qu'il est installé.

    Pour Nvidia cé aussi un rpm à installé (sans être sous X cé mieux) et il faut ensuite modifié ton XF86Config (/etc/X11, si je me souvient bien). Pour la modif tu dois avoir un README ou un INSTALL avec le fichier rpm ou sur le site. En tous cas pour unreal 2003 ca tournais aussi bien sous linux que windows (ptète un peu plus beau sous windows) et call of duty parreil.
    baze, 26 Février 2004
    #27
  8. Offline
    Siluro Touriste
    lol pas fait attention

    ce qui est drole c qu'il y a pas de drive pour linux sur le site du constructeur
    http://ts.hercules.com/fr/index.php?pg=view_files&gid=1&fid=1&pid=149&cid=1
    Siluro, 27 Février 2004
    #28
  9. Offline
    TheNastyBoy B0rn t0 b3 r00t
    En fait chez Nvidia ils ne font plus ni rpm ni .deb ni .tar.gz, il s'agit d'un .bin et ensuite on modifie le fichier de XFree.

    Oui c'est vrai ce n'est sans doute que le fichier de conf mais comme il n'a pas désactivé sa carte intégrée, mieux vaut faire ça proprement...
    TheNastyBoy, 27 Février 2004
    #29
  10. Offline
    xsmarty Touriste
    NE REINSTALLE PAS TON SYSTEME !!!!
    La soluce est toute Bète..
    soit tu désactive dans ton bios, et ca ira mieux

    on peux tjrs solutionner le problème sans désactivé l'embedded.

    ouvre une console et tappe 'lspci'
    lspci en console t'affichera une liste avec tout les perifs pci et leur adresse sur le bus pci.
    genre
    1:0F:0: ati compatible vga 9800(ati)
    etc..
    note l'id de ta carte
    attention; cet id est donné en Hexadécimal
    c a dire ke le 1:0F:0 correspondrais a 1:15:0 en décimal.
    bref retiens en décimal ce fameux chiffre t'en a besoin apres.

    apres
    dans ton fichier /etc/X11/XF86config-4 (9.1 ca doit etre un XF4.xx)

    a la section decives rajoute

    BusID "PCI:1:13:0"

    OU tu marque PCI (majuscules) : le premier chiffre (1) : le second 13 par exmple : 0 ..

    grace a ca XFree86 il saura quelle carte il a a employer pour envoyer les infos a l'affichage

    si ca marche pas au pire dans cette meme section device, change le nom du pilote par 'Vesa'.. et essaye comme ca..

    si ca marche tjrs pas .. eu .. achete un macintosh.. a++
    xsmarty, 3 Mars 2004
    #30
  11. Offline
    Xaab Touriste
    :shock: WOW :shock:
    Merci xsmarty :)

    Je m'éssaye ça :wink:
    Xaab, 3 Mars 2004
    #31
Statut de la discussion:
Fermée.