[Linux] prob lors instal amsn

Discussion dans 'Windows' créé par _Oby, 23 Septembre 2004.

Statut de la discussion:
Fermée.
  1. Offline
    _Oby ex membre
    salut salut,je suis nouveau sous Linux,
    et en essayant d installer amsn, j ai un message d erreur que j arrive pas
    à résoudre

    voici le message :

    [root@localhost DL Setup]# urpmi amsn-0.93-1.i586.rpm
    installation de amsn-0.93-1.i586.rpm

    L'installation a échoué:
    libtcl8.4.so est nécessaire à amsn-0.93-1
    libtk8.4.so est nécessaire à amsn-0.93-1
    perl(File::Basename) est nécessaire à amsn-0.93-1
    perl(File::Copy) est nécessaire à amsn-0.93-1
    //

    j ai recherché sur rpmfind, si il y avait des packages portant ces noms
    mais j'ai rien trouvé

    je n'ai aucune idée de ce que je dois faire pour installé ces 4 fichiers manquant

    besoin d'un petit coup de pouce :)
    Merci

    PS: j ai fais une recherche pour voir si le probleme a deja été posé, mais rien trouvé. désolé si j ai mal cherché
    _Oby, 23 Septembre 2004
    #1
  2. Offline
    Jo_ m00
    Jo_, 23 Septembre 2004
    #2
  3. Offline
    dagibbon Elite
    t'as quelle distribution?

    essayes rpm -ivh amsn-0.93-1.i586.rpm

    le -ivh c'est "I"nstallation, "v"erbose (il met tout a l'ecran), le "h" c'est pour le formattage de ton affichage

    eventuellement ajoutes l'option V (majuscule) pour la vérification du package. Tu dois faire le rpm ABSOLUMENT en root evidemment.

    puis un vieux man rpm si tu t'en sors pas ;)
    dagibbon, 23 Septembre 2004
    #3
  4. Offline
    _Oby ex membre
    distribution mandrake

    donc semblerai ke j ai le bon package, v essayer de faire ce que tu as mis
    merci

    [edit]

    [root@localhost DL Setup]# rpm -ivh amsn-0.93-1.i586.rpm
    error: failed dependencies:
    libtcl8.4.so is needed by amsn-0.93-1
    libtk8.4.so is needed by amsn-0.93-1
    perl(File::Basename) is needed by amsn-0.93-1
    perl(File::Copy) is needed by amsn-0.93-1
    [root@localhost DL Setup]#

    ca a l air d etre la meme chose :-(
    _Oby, 23 Septembre 2004
    #4
  5. Offline
    dagibbon Elite
    eventuellement essayes le rpm manager de drake, suffit de cliquer deux fois dessus pour qu'il extract tout (faut aussi etre en root)
    dagibbon, 23 Septembre 2004
    #5
  6. Offline
    _Oby ex membre

    nop ca va pas :-(
    _Oby, 23 Septembre 2004
    #6
  7. Offline
    dagibbon Elite
    comme dit B[a]H, vérifies si le package est pour la bonne distro...

    Sinon, elle me semble incomplete au vu du vieux message d'erreur. Repompes la pour tester...Puis le cas echeant tu peu la prendre via le gestionnaire de package du panneau de configuration mandrake (je pense)
    dagibbon, 23 Septembre 2004
    #7
  8. Offline
    theodorus ex membre
    Je ne sais pas comment marche mandrake, mais en toute logique j'essayerais "#urpmi amsn".
    theodorus, 23 Septembre 2004
    #8
  9. Online
    Fish Bouillant même !
    un rpm c un rpm c pas une question de distro mais une question de version de kernel ! un rpm etant de toute facon un Redhat Package Manager

    c est juste qu il te manque des packages pour ton install

    si tu as besoin d un coup de main efficace et simple va sur : http://www.lea-linux.org/

    ;)
    Fish, 23 Septembre 2004
    #9
  10. Offline
    theodorus ex membre
    ?
    theodorus, 23 Septembre 2004
    #10
  11. Offline
    TheNastyBoy B0rn t0 b3 r00t
    Le rpm que tu essaies d'installer est pour Mandrake 10.0 .
    Est-ce bien celle-là que tu as?
    Il me semble que non, car sinon au lieu de te dire :
    Code:
    L'installation a échoué:
    libtcl8.4.so est nécessaire à amsn-0.93-1
    libtk8.4.so est nécessaire à amsn-0.93-1
    perl(File::Basename) est nécessaire à amsn-0.93-1
    perl(File::Copy) est nécessaire à amsn-0.93-1 
    Il te dirait que des paquetages (et non des fichiers) sont nécessaires et te proposerait de les installer au passage.

    Il se peut aussi que tu soies sous Mandrake 10.0, mais qu'il te manque un ou plusieurs cd contenant les paquetages nécessaires... et comme tu ne les avais sans doute pas à l'installation, il ne risquait pas de savoir où ils sont...

    J'espère avoir été compréhensible :roll:
    TheNastyBoy, 23 Septembre 2004
    #11
  12. Offline
    Zloupy *
    c drole j'ai fait la meme chose et chez moi c passé nickel,; sur une Mdk 10.0 kernel-source 2.3.6-7 j crois
    Zloupy, 23 Septembre 2004
    #12
  13. Offline
    TheNastyBoy B0rn t0 b3 r00t
    Le problème ce n'est pas le noyau... le problème c'est qu'il n'a pas la bonne version de libtcl, ni celle de libtk, ni perl.

    Donc, si Oby[-] veut bien exécuter les commandes suivantes et nous donner le résultat :
    Code:
    #uname -ar
    Code:
    rpm -qa | grep tcl
    Code:
    rpm -qa | grep tk
    Code:
    rpm -qa | grep perl
    ça nous aiderait beaucoup à le conseiller sur le(s) paquetage(s) à installer[/quote]
    TheNastyBoy, 23 Septembre 2004
    #13
  14. Offline
    sebge2 Touriste
  15. Offline
    _Oby ex membre
    Code:
    [root@localhost DL Setup]# urpmi amsn-0.83-3mdk.i586.rpm
    Les paquetages suivants ont des signatures non valides:
    amsn-0.83-3mdk.i586.rpm
    Voulez-vous continuer l'installation ? (o/N) o
    installation de amsn-0.83-3mdk.i586.rpm
    
    L'installation a échoué:
            tcl >= 8.4.2 est nécessaire à amsn-0.83-3mdk
            tk >= 8.4.2 est nécessaire à amsn-0.83-3mdk
            libtcl8.4.so est nécessaire à amsn-0.83-3mdk
            libtk8.4.so est nécessaire à amsn-0.83-3mdk
    [root@localhost DL Setup]#
    
    

    meme probleme
    _Oby, 23 Septembre 2004
    #15
  16. Offline
    _Oby ex membre
    [/quote]


    Code:
    [root@localhost DL Setup]# #uname -ar
    [root@localhost DL Setup]# rpm -qa | grep tcl
    tcl-8.3.3-21mdk
    [root@localhost DL Setup]# rpm -qa | grep tk
    libgtk+-x11-2.0_0-2.2.1-2mdk
    libgtk+2.0_0-2.2.1-2mdk
    gtkdialogs-2.0-3mdk
    libgtkhtml2_0-2.2.0-2mdk
    libfltk1.1-1.1.2-1mdk
    nautilus-gtkhtml-0.3.2-5mdk
    libgtkmm1.2-1.2.10-1mdk
    gtkhtml-1.1.8-2mdk
    gtk-engines-0.12-7mdk
    libgtk+1.2-1.2.10-32mdk
    gtk+2.0-2.2.1-2mdk
    tk-8.3.3-21mdk
    gtk-engines2-2.2.0-2mdk
    libexif-gtk4-0.3.3-2mdk
    gtkam-0.1.10-2mdk
    libatk1.0_0-1.2.2-1mdk
    gtk+mdk-0.1.6-14mdk
    libgtkxmhtml1-1.4.2-3mdk
    tkinter-2.2.2-6mdk
    libgtkhtml1.1_3-1.1.8-2mdk
    libgtk+1.2-devel-1.2.10-32mdk
    [root@localhost DL Setup]# rpm -qa | grep perl
    perl-GTK-GdkImlib-0.7008-26mdk
    perl-HTML-Parser-3.27-1mdk
    perl-libwww-perl-5.69-1mdk
    perl-XML-Twig-3.09-2mdk
    perl-base-5.8.0-19mdk
    perl-5.8.0-19mdk
    perl-URPM-0.81-13mdk
    perl-Locale-gettext-1.01-7mdk
    perl-DateManip-5.40-4mdk
    perl-GTK2-0.0.cvs.2003.03.04.1-2mdk
    perl-HTML-Tagset-3.03-5mdk
    perl-CGI-2.810-3mdk
    perl-Net_SSLeay-1.21-1mdk
    perl-Authen-PAM-0.13-4mdk
    perl-XML-Parser-2.31-6mdk
    perl-GTK-Glade-0.7008-26mdk
    perl-Term-Readline-Gnu-1.13-1mdk
    perl-MDK-Common-1.0.4-23mdk
    perl-GTK-0.7008-26mdk
    perl-GTK-GdkPixbuf-0.7008-26mdk
    perl-URI-1.23-1mdk
    perl-devel-5.8.0-19mdk
    perl-GTK-Gnome-0.7008-26mdk
    [root@localhost DL Setup]#
    
    Voila ce ke ca dis :)
    _Oby, 23 Septembre 2004
    #16
  17. Offline
    TheNastyBoy B0rn t0 b3 r00t
    Oops, autant pour moi la première commande je me suis gouré, tape plutôt :
    Code:
    uname -ar
    Et tu n'as toujours pas répondu sur ta version de Mandrake (bah je le saurai quand tu auras posté le résultat de la commande :p)

    Sinon pour le moment c'est normal qu'urpmi te jette, tu n'as pas les bonnes versions. Au fait, n'installes pas de version d'amsn inférieure à 0.90, question de compatibilité avec le réseau MSN...
    TheNastyBoy, 24 Septembre 2004
    #17
Statut de la discussion:
Fermée.