Probleme de ftp !!!

Discussion dans 'Hardware, matos' créé par guslinux, 1 Mai 2003.

Statut de la discussion:
Fermée.
  1. Offline
    guslinux Gamerz'ien
    Bonjour, j'ai installé recement un routeur, et depuis ce moment là, mon serveur ftp (proftpd) n'est plus accessible partout !!, généralement des qu'un pc qui veut s'y connecter est derière un routeur, il n'a pas acces !!! alors que le serveur apache, est tout ce qu'il y a d'accessible et de + rapide !!! en local, j'ai acces a mon ftp par son adresse ip (192.168.0.11) et une fois que je demande la redirection homeip.net, il ne le trouve pas ...
    guslinux, 1 Mai 2003
    #1
  2. Offline
    Shady Touriste
    Faut simplement configuré ton réseau de tel maniere que le routeur fasse passerelle. cad

    Ton réseau local t en 192.168.0.*
    et sur le net tu est en 80.*.*.*
    donc le routeur de faire la paserelle entre les 2 subnet sinon, evidement personne pourra jamais joindre ton ftp venant du net..
    Shady, 1 Mai 2003
    #2
  3. Offline
    guslinux Gamerz'ien
    bein j'ai deja configuré les "serveurs vitruels" comme ils disent, mais c'est un truc bizzare, quand qqun est derière un routeur, il n'a pas acces ... mais je n'ai pas ce probleme avec apache !!! et quand je me connecte a l'école, vitesse d'affichage sur le ftp est nikelle !!!
    guslinux, 1 Mai 2003
    #3
  4. Offline
    Shady Touriste
    Faudrai que je voye cela de met yeux, mais a mon avis suffit de changer ton réseau lan avec un subnet en 255.0.0.0
    Shady, 1 Mai 2003
    #4
  5. Offline
    guslinux Gamerz'ien
    Voila ce que mon client ftp me dis quand je lance la connection par la redirection ...

    Recherche de easyuser.homeip.net
    Essai avec 212.68.254.246.brutele.be:21
    Connecté sur easyuser.homeip.net:21
    220 Bienvenue sur mon FTP
    USER anonymous

    331 Anonymous login ok, send your complete email address as your password.
    PASS xxxx
    230 Anonymous access granted, restrictions apply.
    TYPE I

    200 Type set to I.
    PWD

    257 "/" is current directory.
    PASV

    227 Entering Passive Mode (192,168,0,11,4,4).
    LIST -aL



    Et voila, plus rien a partir de ce moment là...

    alors que quand j'utiliser l'IP local :

    Recherche de 192.168.0.11
    Essai avec 192.168.0.11:21
    Connecté sur 192.168.0.11:21
    220 Bienvenue sur mon FTP
    USER anonymous

    331 Anonymous login ok, send your complete email address as your password.
    PASS xxxx
    230 Anonymous access granted, restrictions apply.
    TYPE I

    200 Type set to I.
    PWD

    257 "/" is current directory.
    PASV

    227 Entering Passive Mode (192,168,0,11,4,6).
    LIST -aL

    150 Opening ASCII mode data connection for file list
    226-Transfer complete.
    226 Quotas off
    guslinux, 1 Mai 2003
    #5
  6. Offline
    Shady Touriste
    ha ben c simple, vire dans les option de ton clients ftp le passive mode :)

    A mon sens le prb vien de la.
    Shady, 1 Mai 2003
    #6
  7. Offline
    guslinux Gamerz'ien
    moije vx bien, ms le truc, c'est que il faut que je config qqch sur le serveur, parce que les utlisateur lamda, comment ils font poru changer les params par defaut lol
    guslinux, 1 Mai 2003
    #7
  8. Offline
    Shady Touriste
    Les clients, serrons de tt facon obliger d'enlevé le passive mode..

    Faut juste le mettre dans le message d'aceille
    Shady, 2 Mai 2003
    #8
  9. Offline
    guslinux Gamerz'ien
    j'ai desactivé le mode passif... ca chage rien, le client attend que le serveur lui envoie la liste de fichier, j'ai essayé de bloquer les transmition en binaire ou en ascii, j'ai defini les port 60000 à 65500 pour le mode passif, et j'ai redirigé ces port là sur mon serveur à partir du routeur ...
    guslinux, 2 Mai 2003
    #9
Statut de la discussion:
Fermée.