Problement de génération de projet en C :s

Discussion dans 'Web, design' créé par - Lo0, 11 Janvier 2008.

Statut de la discussion:
Fermée.
  1. Offline
    - Lo0 Elite
    Plop, j'ai un probleme bizare. Je m'explique ; j'utilise visual studio 2005 et je travaille sur un solution. Tout ce passe bien, je crée des bibliotheque et de nouveau projet dans ma solution, pas de prob. Je génere un projet (ici stock02), ca génere correctement et ca roule. Je crée un nouveau projet(ici stock03), je copie le fichier source du stock02 et la bardaf, il veut pas me le génerer (j'ai bien mis les dépendances et les repertoires include, librairie comme pour le stock02, tout pareil). J'ai cette erreur ci

    ------ Début de la génération : Projet : Stock03b, Configuration : Debug Win32 ------

    Édition des liens en cours...

    Lecture.lib(Lecture.obj) : warning LNK4075: ' /EDITANDCONTINUE' ignoré à cause de la spécification '/OPT:ICF'

    MSVCRTD.lib(MSVCR80D.dll) : error LNK2005: _strchr déjà défini(e) dans LIBCMT.lib(strchr.obj)

    MSVCRTD.lib(MSVCR80D.dll) : error LNK2005: _free déjà défini(e) dans LIBCMT.lib(free.obj)

    MSVCRTD.lib(MSVCR80D.dll) : error LNK2005: _malloc déjà défini(e) dans LIBCMT.lib(malloc.obj)

    LINK : warning LNK4098: conflit entre la bibliothèque par défaut 'MSVCRTD' et les autres bibliothèques ; utilisez /NODEFAULTLIB:library

    C:\Documents and Settings\***\Mes documents\Visual Studio 2005\Projects\stockol\Debug\Stock03b.exe : fatal error LNK1169: un ou plusieurs symboles définis à différentes reprises ont été rencontrés

    Le journal de génération a été enregistré à l'emplacement "file://c:\Documents and Settings\***\Mes documents\Visual Studio 2005\Projects\stockol\Stock03b\Debug\BuildLog.htm"

    Stock03b - 4 erreur(s), 2 avertissement(s)




    ????

    Sauriez vous d'ou vient l'erreur ?
    - Lo0, 11 Janvier 2008
    #1
  2. Offline
    Bartdude Touriste
    N'aurais-tu pas oublié, dans tes copier/coller, l'une ou l'autre modification de référence ?

    Sorry de pas pouvoir être plus précis, mais bon je fais de l'ASP.NET avec VS2003 donc je suis pas vraiment dans la même situation que toi...
    Bartdude, 11 Janvier 2008
    #2
  3. Offline
    - Lo0 Elite
    Non, rien oublié. J'ai meme refait toutes les opérations pour etre sur.

    Je capte pas :/
    Plus moyen de bosser. Pff


    Edit : ca y'est j'ai trouvé l'erreur.

    Je creais un projet vide au lieu d'une application console win32 :O... Connerie, perdu plein de temps pour rien.
    - Lo0, 11 Janvier 2008
    #3
Statut de la discussion:
Fermée.