[RESOLU]Enlever un 2e Windows

Discussion dans 'Windows' créé par suPr3m_, 13 Février 2006.

Statut de la discussion:
Fermée.
  1. Offline
    suPr3m_ ~ Sony Vaio ~
    Hello! Voilà j'ai un petit souci, je m'explique:

    Ayant eu des soucis avec le PC, j'ai du remettre un windows mais je l'ai d'abord installé sur une autre partition! Ensuite je l'ai réinstallé sur le C. J'utilise celui du C donc j'ai supprimé via windows dans l'autre partition l'autre windows, mais à chaque démarrage il me demanque sur quel windows booter alors que logiquement il n'y en a qu'un seul qui fonctionne. (Je suppose que si je sélectionne l'autre, il ne se passera rien)

    Ma question est donc: comment faire pour qu'il boot comme avant, c'est-à-dire sans me le demander ..

    Merci :wink:
    suPr3m_, 13 Février 2006
    #1
  2. Offline
    TeXx Elite
    j'ai ce probleme aussi :-( donc si quelqu'un pouvait nous aider :p )
    TeXx, 13 Février 2006
    #2
  3. Offline
    luciano L*3*3*T
    Je crois qu’il faut tout formater et réinstaller Windows afin qu’il boot normalement sans te demander de choisir

    Via Partition Magic c’est peut-être possible ? (je pose la question car je connais pas)
    luciano, 13 Février 2006
    #3
  4. Offline
    suPr3m_ ~ Sony Vaio ~
    Arf tout formater je préfère laisser ainsi alors :p
    Il n'y a pas d'autres solutions?
    suPr3m_, 13 Février 2006
    #4
  5. Offline
    Fist Vieux Crouton
    Equipe GamerZ.be
    faut supprimer une ligne de commande
    qui se trouve dans
    panneau de configuration -> system -> avancé -> demarrage et configuration dernier onglet "parametres" -> modifier

    en toute logique vous devriez avoir ça
    mis a part le valeur Timeout
    Code:
    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /fastdetect /NoExecute=OptIn
    Fist, 13 Février 2006
    #5
  6. Offline
    luciano L*3*3*T
    Je m’y étais mal pris à l’époque alors :roll:
    luciano, 13 Février 2006
    #6
  7. Offline
    suPr3m_ ~ Sony Vaio ~
    Bon avec la soluce de Fist, il ne me met plus:

    Donc 2x avec un qui ne fonctionne pas, mais il me met:

    Ou un truc du genre, quand je lance le premier il me demande de le réinstaller (donc c'est le mauvais) et l'autre c'est le bon boot ...

    Donc pas trop de soluce mais j'ai réduit le temps du boot automatique à 11sec au lieu de 30, il lance le bon windows automatiquement de toute façon .. :)
    suPr3m_, 13 Février 2006
    #7
  8. Offline
    Dolu Touriste
    J'ai eu le même problème y a un mois ou deux.

    J'édite dès que je retrouve le lien.


    ... :arrow: : ICI
    Dolu, 13 Février 2006
    #8
  9. Offline
    suPr3m_ ~ Sony Vaio ~
    Merci, je vais regarder à ça! :wink:
    suPr3m_, 13 Février 2006
    #9
  10. Offline
    Fist Vieux Crouton
    Equipe GamerZ.be
    ouais voial il faut mettre le rdisk a 0 :wink:

    j avais plus pensé a ça
    Fist, 13 Février 2006
    #10
  11. Offline
    suPr3m_ ~ Sony Vaio ~
    Mon boot.ini :

    Donc le 2e je met rdisk 0 ?

    edit: y a aucun risque que si ça merde je ne sache plus démarrer?
    suPr3m_, 13 Février 2006
    #11
  12. Offline
    Dolu Touriste
    Non, c'est bon tu peux y aller! :)

    Enfin, chez moi ça a marché!

    Par contre, je trouve bizarre que tu aie partition(6)

    T'as combien de partitions sur ton dd?
    Dolu, 13 Février 2006
    #12
  13. Offline
    suPr3m_ ~ Sony Vaio ~
    Tel qu'il est là ça ne fonctionne pas, j'ai toujours les 2!

    J'ai sur le premier DD (avec le bon windows) 3 partitions (C - D - E) et l'autre DD j'en ai 6 (dont une avec le mauvais win!)
    suPr3m_, 13 Février 2006
    #13
  14. Offline
    litteulcake Not an addict
    J'avais déjà résolu un problème de ce type sur le PC d'un gars qui avait installé une deuxième fois Microsoft Windows "sans le faire exprès" (je me demande toujours comment, mais bon, après plusieurs années d'helpdesk, je me pose plus de question).

    Il faut faire un "fixmbr" dans la console de récupération...

    Voici la procédure :

    1. Configure ton PC pour démarrer à partir du lecteur de CD-ROM dans ton BIOS
    2. Mets un CD XP bootable dans le lecteur
    3. Lorsque le message "Appuyez sur n'importe quelle touche pour démarrer du CD-ROM" s'affiche, tu appuies sur la "n'importe quelle touche"
    4. Quand on le demande, tu choisis de lancer la console de récupération en appuyant sur "R" (au lieu d' "enter" pour installer windows, enfin, il me semble)
    5. Bon, là, tu auras p-e le choix entre 2 install de windows, TE GOURRE PAS, prend celle que tu veux qu'il lance au démarrage (bref, celle que tu veux garder, mais vu ta situation, si tu choisis la mauvaise, à l'étape suivant, il va p-e faire un caca nerveux, mais c'est pas garanti, les mystères de windows sont parfois impénétrables...)
    6. Normalement, il devrait te demander le mot de passe admin
    7. À l'invite de commandes, tu tapes simplement : FIXMBR

    Normalement, tu as un super message d'avertissement qui te dit que c'est dangeureux et tout ça et gnagnagna... Je l'ai fait, j'ai pas eu de problème et je pense avoir décrit plus ou moins bien les étapes que j'avais faites...

    J'espère que ça t'aidera :D

    EDIT : cette manip n'effacera pas la partition windows dont tu veux te débarasser mais il ne te proposera plus de booter dessus

    EDIT2 : attention : si tu as une troisième partition de boot style GNU/Linux, il ne te proposera plus de booter dessus, bref, il va juste garder la partition que tu lui as demandé de "sauver"... Mais bon, d'après ce que je lis plus haut, tu n'as que Windows XP installé sur ta machine.
    litteulcake, 13 Février 2006
    #14
  15. Offline
    Dolu Touriste
    Sinon, si il ne te reste plus qu'un seul OS, dans ton cas la 2ème ligne doit être la même que la première :

    Ca donne ça :
    rdisk(0) : le premier disque physique
    partition(1) : la première partition (C)

    C'est exacement ça que j'ai dans mon boot.ini.
    Dolu, 13 Février 2006
    #15
  16. Offline
    daripper Touriste
    Boot le bon Windows,
    Assures toi que tu vois les fichiers caches,
    Sur ton C: modifie le fichier BOOT.INI afin qu il soit editable (enleve le lecture seul)
    Donc edites ce fichier et assure toi que tu n y trouves que ceci :

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect


    Dans ce cas ci c est un XP Pro...mais ce qui est important c'est le default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS


    pour etre encore plus clair, voici ton BOOT.INI modifie :

    [boot loader]
    timeout=11
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /noexecute=optin /fastdetect
    daripper, 13 Février 2006
    #16
  17. Offline
    suPr3m_ ~ Sony Vaio ~
    Merci pour vos réponses en tout cas! J'ai modifié, je vous dirais quoi demain en rallumant l'ordi (en esperant le voir se rallumer :p ) :wink:
    suPr3m_, 13 Février 2006
    #17
  18. Offline
    Dolu Touriste
    Ha tu entretiens le suspens! :D
    Dolu, 14 Février 2006
    #18
  19. Offline
    Zwane Elite
    si pas de réponse demain matin on sera pourquoi hihi
    Zwane, 14 Février 2006
    #19
  20. Offline
    suPr3m_ ~ Sony Vaio ~
    Suspennnnnnnnns ! Tadaaaaaaa !

    ça a fonctionné niquel, il boot directement sans me demander sur lequel j'aimerais booter!

    Merci à tous! :wink:

    Mon boot.ini final donc (pour ceux qu'auraient le blem):

    suPr3m_, 14 Février 2006
    #20
Statut de la discussion:
Fermée.