edit new pb : Comment créer une boucle [php]

Discussion dans 'Web, design' créé par PiaFlalCoOl, 29 Décembre 2004.

Statut de la discussion:
Fermée.
  1. Offline
    PiaFlalCoOl NiuAge
    -----------Problème résolu---------------
    Voila, j'ai un forum phpbb. Et j'ai vu qu'il était possible de modifier la zone qui est entourée en rouge ci dessous :
    [IMG]

    En fait comment faire pour mettre des images à ces emplacements. :?:

    J'ai cherché, mais pas trouvé...

    THX :D

    au cas ou, l'adresse du forum ou j'ai vu ces modifs : http://flash.media-box.net/

    -----------Nouveau problème-------------
    Aller voir en page 2, mon pb est expliqué. J'aimerai savoir comment faire une boucle en php.
    PiaFlalCoOl, 29 Décembre 2004
    #1
  2. Offline
    Spo0n Dr. Gonzo
    Tu changes les cell_pics.
    Spo0n, 29 Décembre 2004
    #2
  3. Offline
    PiaFlalCoOl NiuAge
    ok, mais je m'en doutais un peu de ça. En fait cellpic, c'est une petite image qu'il répète plusieurs fois. Donc comment faire pour insérer la grande image ?

    Et sais tu me dire dans quel fichier je dois modifier ça ? Parce que avant je maitrisais un peu mieux, mais ça fait longtemps que j'ai pas touché à mon forum.

    thx
    PiaFlalCoOl, 29 Décembre 2004
    #3
  4. Online
    Jereck Procrastinateur
    Equipe GamerZ.be
    Et tu ne sais pas contacter les admin de l'autre forum ?
    Jereck, 29 Décembre 2004
    #4
  5. Offline
    Spo0n Dr. Gonzo
    J'ai plus modifié un phpBB depuis mars moi. ;D
    Euh, je me souviens plus vraiment de laquelle mais regarde aussi le subSilver.css...Essaye de rajouter une classe avec un background-image que tu veux.
    Spo0n, 29 Décembre 2004
    #5
  6. Offline
    PiaFlalCoOl NiuAge
    oula, rajouter une classe, tu m'en demande trop. J'y connais RIEN en phpbb, juste a un moment quand je rajoutais des mods a mon forum, j''ai fini par savoir a peu pres quelles zones étaient codées dans quel fichier mais ça s'arrêtait la ehhe.

    Contacter les admin...c'est pas une mauvaise idée.
    PiaFlalCoOl, 29 Décembre 2004
    #6
  7. Offline
    PiaFlalCoOl NiuAge
    J'ai contacté l'admin du site, j'espère qu'il me répondra.
    PiaFlalCoOl, 29 Décembre 2004
    #7
  8. Offline
    PiaFlalCoOl NiuAge
    Quelqu'un m'a filé ça
    Code:
    ouvrir index_body.tpl 
    
    trouver 
    <td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br /> 
    
    remplacer par 
    
    <td class="row1" width="100%" height="50"{catrow.forumrow.BACKINFO}><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br /> 
    
    ouvrir index.php 
    
    trouver : 
    
                         $row_color = ( !($i % 2) ) ? $theme['td_color1'] : $theme['td_color2']; 
                         $row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2']; 
    
    ajouter après 
    
                         $backinfo = ($forum_id == 1) ? ' background="./fondbat.gif" style="background-repeat:no-repeat; background-position:right"' : ''; 
    
    trouver : 
                            'MODERATORS' => $moderator_list, 
    
    ajouter après : 
    
                            'BACKINFO' => $backinfo,
    
    mais ou est ce que je dois mettre mon image ? Je dois l'appeler fondbat.gif ? et quelle doit être sa dimension ? thx
    PiaFlalCoOl, 29 Décembre 2004
    #8
  9. Offline
    Sokin ex membre
    Oui ton image doit se nommé fondbat.gif (la taille, ben la taille du cadre donc ça dépend., fait des tests pour voir ;))

    Ensuite ta ligne de code
    Code:
    $backinfo = ($forum_id == 1) ? ' background="./fondbat.gif" style="background-repeat:no-repeat; background-position:right"' : '';
    Si tu veux mettre une image à plusieurs forums, il te suffit de repeter cette ligne de code en changeant $forum_id == 2 par exemple cette fois ci je pense.. Et evidemment changer l'image de fond ;)
    Sokin, 29 Décembre 2004
    #9
  10. Offline
    PiaFlalCoOl NiuAge
    ok c cool, je vais test.
    PiaFlalCoOl, 29 Décembre 2004
    #10
  11. Offline
    PiaFlalCoOl NiuAge
    grrrrr ça marche pas...
    J'ai bien fait toutes les modifs...
    Ou est ce que je dois mettre mon image fondbat.gif ?? dans le template subsilber je pense... mais ça marche pas.
    PiaFlalCoOl, 29 Décembre 2004
    #11
  12. Online
    Jereck Procrastinateur
    Equipe GamerZ.be
    C'est un lien relatif ...

    Quand l'image n'apparait pas, fait un clic-droit, propriétés, et regarde l'adresse où elle devrait se trouver.
    Jereck, 29 Décembre 2004
    #12
  13. Offline
    PiaFlalCoOl NiuAge
    Ce que tu dis ne marche pas, parce que la zone ou je veux mettre l'image n'est pas, par défault, une image ! C'est la toute la difficulté, sinon j'aurai modifié l'image tranquillement.

    Je sais pas si tu vois ce que je veux dire.
    PiaFlalCoOl, 29 Décembre 2004
    #13
  14. Online
    Jereck Procrastinateur
    Equipe GamerZ.be
    Tu as modifié 'index_body.tpl' ?
    Jereck, 29 Décembre 2004
    #14
  15. Offline
    PiaFlalCoOl NiuAge
    ouais, bien sur, je pense avoir fait exactement ce qui était demandé. Le prob, c'est que je l'ai déja pas mal modifié mon forum, c'est possible que certaines modifs influent... mais je pense pas.

    J'ai trouvé ça, je pense que ça peut aider mais je comprend pas tout. http://www.aginum.net/phpbb/pages/templates.htm#10

    Moi ce que je veux modifier, c'est le numéro 11 (tu comprendras en regardant le site)
    PiaFlalCoOl, 29 Décembre 2004
    #15
  16. Offline
    Sokin ex membre
    Tu veux la meme image pour chaque ligne ou pas à chaque ?


    Je comprend pas trop ton problème en ce moment :d
    Sokin, 29 Décembre 2004
    #16
  17. Offline
    PiaFlalCoOl NiuAge
    J'aimerai qu'elle soit différente a chaque ligne car je compte pas en mettre sur chaque.

    Mon problème est tres simple :

    Voila une ligne de mon forum :
    [IMG]

    et voila une ligne d'un autre forum :
    [IMG]

    J'aimerai pouvoir mettre une image a la même place qu'eux.

    Puis j'ai cru trouver le code pour réaliser ça, et ça marche pas.
    Voila mon problème.

    THX pour l'aide !
    PiaFlalCoOl, 29 Décembre 2004
    #17
  18. Offline
    Sokin ex membre
    Je pense que dans le code, il y a une erreur.. essaie de remplacer ce truc :
    Code:
    <td class="row1" width="100%" height="50"{catrow.forumrow.BACKINFO}><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
    Par
    Code:
    <td class="row1" width="100%" height="50">{catrow.forumrow.BACKINFO}<span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
    Sokin, 29 Décembre 2004
    #18
  19. Offline
    PiaFlalCoOl NiuAge
    thx mais ça n'a quand même pas marché. Pourtant j'en ai installé pas mal des mods... je verrai ça demain :p

    le prob ne viendrai pas d'ici ? ::>
    Code:
    $backinfo = [color=red]($forum_id == 1)[/color] ? ' background="./fondbat.gif" style="background-repeat:no-repeat; background-position:right"' : '';
    
    
    $forum_id == 1
    PiaFlalCoOl, 30 Décembre 2004
    #19
  20. Online
    Jereck Procrastinateur
    Equipe GamerZ.be
    Tu dois bien changer la condition en mettant le forum_id qui correspond chez toi
    Jereck, 30 Décembre 2004
    #20
Statut de la discussion:
Fermée.