Installer WoW sur Linux

Discussion dans 'MMoG' créé par Sigmund, 2 Février 2009.

Statut de la discussion:
Fermée.
  1. Offline
    Sigmund Philololologue
    en effet le copier coller fonctionne!

    Par contre, même après avoir édité config.wtf en rajoutant la ligne, j'ai toujours 40 fps..

    (pour l'éditer, j'ai simplement ouvert avec un logiciel de traitement de texte, rajouté la ligne et ctrl s.. ça a bien créé la ligne, mais j'ai un autre fichier qui a apparu: Config.wtf~ (que je ne sais pas ouvrir)
    Sigmund, 3 Février 2009
    #21
  2. Offline
    Arnpsyke Charlatan
    essaye de lancer wow -opengl pour voir . Quelle est ta carte graphique ?
    Arnpsyke, 3 Février 2009
    #22
  3. Offline
    Sigmund Philololologue
    comment je fais pour lancer wow -opengl? :-D


    J'ai une 8800 GTS 320 Mo :)
    Sigmund, 3 Février 2009
    #23
  4. Offline
    Arnpsyke Charlatan
    alors tu devrais bien avoir plus de fps :

    -regarde si tu as bien installé les derniers drivers
    -si tu as compiz , il vaut mieux le désactiver (telecharge le packet fusion-icon)
    -regarde dans le fichier config.wtf s'il n'y a pas SET gxApi "d3d" (si oui supprime le)
    -n oublie que en copiant collant tu as mis ta config windows dessus, il vaut parfois mieux effacer completement le répertoire WTF et remettre les parametres dans wow manuellement
    - si cela va vraiment pas : installe le plugin advanced wine configuration pour playonlinux qui te permettra d'optimiser l opengl pour wine
    -verifie que le son alsa est bien activé

    pour lancer wow.exe -opengl tu fais juste une modif du raccourci que playonlinux a du te mettre sur ton bureau
    Arnpsyke, 3 Février 2009
    #24
  5. Offline
    Sigmund Philololologue
    okay, je vais tester tout ça
    Sigmund, 3 Février 2009
    #25
  6. Offline
    Sigmund Philololologue
    Je reste perplexe.

    Les derniers drivers sont bien installés, selon Envy. J'ai désactivé compiz. Mon config.wtf ne contient pas de d3d, et lorsque j'efface ce dernier, wow plante complètement (et je me retrouve en 800*600)

    Voici une copie de mon config.wtf (j'ai enlevé le nom de compte évidemment)

    SET locale "frFR"
    SET coresDetected "2"
    SET timingTestError "0"
    SET hwDetect "0"
    SET gxColorBits "24"
    SET g:cool:epthBits "24"
    SET gxResolution "1440x900"
    SET gxMultisampleQuality "0.000000"
    SET gxFixLag "0"
    SET videoOptionsVersion "1"
    SET pixelShaders "1"
    SET movie "0"
    SET Gamma "0.900000"
    SET readTOS "1"
    SET readEULA "1"
    SET readTerminationWithoutNotice "1"
    SET showToolsUI "1"
    SET Sound_VoiceChatInputDriverName "Réglage du système"
    SET Sound_VoiceChatOutputDriverName "Réglage du système"
    SET Sound_OutputDriverName "System Default"
    SET Sound_MasterVolume "1"
    SET Sound_SFXVolume "0.5"
    SET Sound_MusicVolume "0.20000000298023"
    SET Sound_AmbienceVolume "0.60000002384186"
    SET realmList "eu.logon.worldofwarcraft.com"
    SET patchlist "eu.version.worldofwarcraft.com"
    SET SmallCull "0.010000"
    SET DistCull "500.000000"
    SET farclip "1277"
    SET specular "1"
    SET particleDensity "1.000000"
    SET groundEffectDensity "64"
    SET groundEffectDist "140"
    SET realmName "Hyjal"
    SET gameTip "123"
    SET uiScale "0.83999997377396"
    SET ChatMusicVolume "0.28000000119209"
    SET ChatSoundVolume "0.31999999284744"
    SET ChatAmbienceVolume "0.31999999284744"
    SET OutboundChatVolume "2.5"
    SET InboundChatVolume "1"
    SET VoiceActivationSensitivity "0.099999994039536"
    SET readScanning "-1"
    SET readContest "-1"
    SET VoiceChatMode "1"
    SET PushToTalkButton "²"
    SET shadowLevel "0"
    SET weatherDensity "0"
    SET CombatLogRangeParty "200"
    SET CombatLogRangePartyPet "200"
    SET CombatLogRangeFriendlyPlayers "200"
    SET CombatLogRangeFriendlyPlayersPets "200"
    SET CombatLogRangeHostilePlayers "200"
    SET CombatLogRangeHostilePlayersPets "200"
    SET CombatLogRangeCreature "200"
    SET CombatDeathLogRange "200"
    SET Sound_EnableErrorSpeech "0"
    SET gxMultisample "4"
    SET textureFilteringMode "5"
    SET showPartyDebuffs "0"
    SET installType "Retail"
    SET portal "eu"
    SET environmentDetail "1.5"
    SET useUiScale "1"
    SET accountName "liiitwowtupues"
    SET Sound_EnableReverb "1"
    SET Sound_EnableSoundWhenGameIsInBG "1"
    SET EnableVoiceChat "1"
    SET mouseSpeed "1"
    SET EnableMicrophone "0"
    SET SoundOutputSystem "1"
    SET SoundBufferSize "150"
    SET gxApi "opengl"
    SET gxRefresh "50"
    SET checkAddonVersion "0"
    SET lastCharacterIndex "3"

    Pour le son, dois-je changer "Réglage du système" par ALSA?
    Sigmund, 3 Février 2009
    #26
  7. Offline
    Sigmund Philololologue
    J'ai changé en ALSA et le son fonctionne, c'est déjà ça :D
    Sigmund, 3 Février 2009
    #27
  8. Offline
    Arnpsyke Charlatan
    vraiment étrange, ton fichier config est bon et les problemes de lenteur chez moi sont uniquement dû si je laisse d3d dans le fichier config. Si je mets opengl, le jeu ne plante pas mais est non seulement rapide. Essaye d'installer le plugin advanced wine configuration pour playonlinux afin de selectionner le parametre opengl pour wow. Si tu n y arrives pas alors reste en D3D et installe dans ton prefix wow DIRECTX9 en plus
    Arnpsyke, 3 Février 2009
    #28
  9. Offline
    Sigmund Philololologue
    Donc comme dit plus haut le son fonctionne.

    Le nombre de fps est vraiment bof (45-50 à IF, moins sur mon tapis volant dans les pics foudroyés), et je n'arrive pas à bien régler le truc. Pourtant j'ai bien mis "opengl" avec wine advanced.

    Le problème vient peut-être du fait que PlayonLinux n'a pas installé le jeu correctement: je n'ai pas de raccourci, et lorsque j'ouvre play on linux et que je liste mes jeux, il ya WorldofWacraft et World of Warcraft. Aucun n'est lançable.. :s

    Par contre j'ai réussi à configurer l'un des deux via le wine advanced
    Sigmund, 3 Février 2009
    #29
  10. Offline
    zoheir cvm.mangaleet()
    SET gxRefresh "50"

    refresh rate?
    change :[]
    zoheir, 3 Février 2009
    #30
  11. Offline
    Sigmund Philololologue
    J'ai un peu chipoté..

    J'ai réussi à lancer WoW via le terminal, et ce avec l'option -opengl

    Voici ce que me donne le terminal:


    PHP:
    sigmund@sigmund-desktop:~/.PlayOnLinux/wineprefix/WorldOfWarcraft/drive_c/Program Files/World of Warcraftwine Wow.exe -opengl
    fixme
    :advapi:SetSecurityInfo stub
    archive Data
    \frFR\patch-frFR.MPQ opened
    archive Data
    \patch.MPQ opened
    archive Data
    \frFR\patch-frFR-2.MPQ opened
    archive Data
    \patch-2.MPQ opened
    archive Data
    \expansion.MPQ opened
    archive Data
    \lichking.MPQ opened
    archive Data
    \common.MPQ opened
    archive Data
    \common-2.MPQ opened
    archive Data
    \frFR\locale-frFR.MPQ opened
    archive Data
    \frFR\speech-frFR.MPQ opened
    archive Data
    \frFR\expansion-locale-frFR.MPQ opened
    archive Data
    \frFR\lichking-locale-frFR.MPQ opened
    archive Data
    \frFR\expansion-speech-frFR.MPQ opened
    archive Data
    \frFR\lichking-speech-frFR.MPQ opened
    fixme
    :win:EnumDisplayDevicesW ((null),0,0x39edbc,0x00000000), stub!
    fixme:d3d:IWineD3DImpl_FillGLCaps OpenGL implementation supports 32 vertex samplers and 32 total samplers
    fixme
    :d3d:IWineD3DImpl_FillGLCaps Expected vertex samplers MAX_TEXTURES(=8) > combined_samplers
    fixme
    :win:EnumDisplayDevicesW ((null),0,0x39eba8,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f2d8,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f434,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f5a0,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f59c,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f530,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f520,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f018,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39f150,0x00000000), stub!
    fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x141820,0x141720): stub
    fixme
    :win:EnumDisplayDevicesW ((null),0,0x39df1c,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x39df44,0x00000000), stub!
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
    fixme
    :wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 5000
    fixme
    :wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
    fixme
    :wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 5000
    fixme
    :reg:GetNativeSystemInfo (0x374028c4using GetSystemInfo()
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUESTUB
    fixme
    :wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUESTUB
    fixme
    :winsock:WSAIoctl unsupported WS_IOCTL cmd (9800000c)
    fixme:win:EnumDisplayDevicesW ((null),0,0x39dae4,0x00000000), stub!
    fixme:imm:ImmReleaseContext (0x200280x13be28): stub
    fixme
    :win:EnumDisplayDevicesW ((null),0,0x39ded4,0x00000000), stub!

    Il y a donc bien des problèmes à résoudre (enfin, j'imagine que "fixme" veut bien dire cela :p)
    Sigmund, 3 Février 2009
    #31
  12. Offline
    Sigmund Philololologue

    C'est ce que je me suis dit, mais comme c'est le fichier config importé de win où j'avais 75 fps..
    Sigmund, 3 Février 2009
    #32
  13. Offline
    Sigmund Philololologue
    Bon j'ai quand même changé, et il s'est passé un truc "bizarre": à des moments j'avais 85 fps, à d'autres 35-40..

    (j'ai mis le refresh à 100)

    C'est tout à fait jouable, mais je ne comprends juste pas :-(
    Sigmund, 3 Février 2009
    #33
  14. Offline
    Sigmund Philololologue
    (ah et tiens d'ailleurs selon ce que j'ai collé du terminal lorsque j'ai lancé wow, il y a une erreur d3d.. :s)
    Sigmund, 3 Février 2009
    #34
  15. Offline
    Sigmund Philololologue
    Euh, question con mais.. Je ne devrais pas mettre les majuscules? (je ne suis pas chez moi là, je testerai en rentrant)

    SET gxApi "OpenGL"
    Sigmund, 3 Février 2009
    #35
  16. Offline
    Arnpsyke Charlatan
    oui sorry, c est bien OpenGL en majuscules pour le O et le GL :)
    Arnpsyke, 3 Février 2009
    #36
  17. Offline
    Sigmund Philololologue
    J'ai mis les majuscules et ça ne change pas grand chose (moyenne de 45-50 fps, avec des pointes à 85 pendant 2 secondes environ).

    La souris disparait de temps en temps, aussi (comme avant)

    Je ne comprends pas :-D

    Sinon c'est tout à fait jouable quoi, hier on a fait sartha 25 dans ces conditions en 33 minutes, j'étais deuxième au dps donc bon.. (looté les gants t7 25 d'ailleurs :-D)

    mais ça m'énerve de pas comprendre pourquoi :-D
    Sigmund, 4 Février 2009
    #37
  18. Offline
    Sigmund Philololologue
    Et bien.. nous avons perdu le soldat son :-D
    Sigmund, 4 Février 2009
    #38
  19. Offline
    Arnpsyke Charlatan
    c'est sur que c'est énervant mais du moment que c'est jouable !

    ps : encore probleme de son ?
    Arnpsyke, 4 Février 2009
    #39
  20. Offline
    Sigmund Philololologue
    non, le son est revenu :-D

    J'ai été sur le site ubuntu anglophone qui proposait aussi des solutions/tweaks pour le low framerate et le son (dont créer un autre serveur X, ou activer directx), aucune n'a fonctionné :-D

    Faudrait voir combien d'fps ont d'autres gens avec une CG similaire.. (j'ai aussi pour 45 Mo d'addons qui tournent derrière, et avec WOLTK le jeu au total pèse près de 15 Go :-s)

    Mais bon, si tu dis qu'en OpenGL ça devrait mieux tourner que sur win..

    (PS: pour avoir les derniers drivers via EnvyNG, il faut bien le laisser choisir automatiquement non?)

    En tous cas, merci de ton implication :)
    Sigmund, 5 Février 2009
    #40
Statut de la discussion:
Fermée.